summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/oroborus-keylaunch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/oroborus-keylaunch')
-rw-r--r--x11-misc/oroborus-keylaunch/Manifest1
-rw-r--r--x11-misc/oroborus-keylaunch/metadata.xml10
-rw-r--r--x11-misc/oroborus-keylaunch/oroborus-keylaunch-1.3.9.ebuild33
3 files changed, 44 insertions, 0 deletions
diff --git a/x11-misc/oroborus-keylaunch/Manifest b/x11-misc/oroborus-keylaunch/Manifest
new file mode 100644
index 000000000000..469eb5bbccbb
--- /dev/null
+++ b/x11-misc/oroborus-keylaunch/Manifest
@@ -0,0 +1 @@
+DIST keylaunch_1.3.9.tar.gz 80286 SHA256 213da77e9263e6aa7edbb1204402ef55d5daff2cd66add2cacbf84a1206da1ef
diff --git a/x11-misc/oroborus-keylaunch/metadata.xml b/x11-misc/oroborus-keylaunch/metadata.xml
new file mode 100644
index 000000000000..47fa4b0fccba
--- /dev/null
+++ b/x11-misc/oroborus-keylaunch/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+ <longdescription>
+ KeyLaunch is a small utility for binding commands to a hot key. It reads a configuration
+ file in ~/.keylaunchrc. KeyLaunch uses Ctrl, Alt and Shift as modifier keys,
+ the hotkey is up to the user.
+ </longdescription>
+</pkgmetadata>
diff --git a/x11-misc/oroborus-keylaunch/oroborus-keylaunch-1.3.9.ebuild b/x11-misc/oroborus-keylaunch/oroborus-keylaunch-1.3.9.ebuild
new file mode 100644
index 000000000000..f367bd5e9435
--- /dev/null
+++ b/x11-misc/oroborus-keylaunch/oroborus-keylaunch-1.3.9.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+MY_PN=${PN/oroborus-//}
+
+DESCRIPTION="utility for binding keys in Oroborus"
+HOMEPAGE="http://www.oroborus.org"
+SRC_URI="mirror://debian/pool/main/k/${MY_PN}/${MY_PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libX11
+ !x11-wm/oroborus-extras"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_prepare() {
+ sed -e "s: -g -O2 -Wall::" \
+ -e "/^install:/s/install-docs//" \
+ -i Makefile.in || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README docs/example_rc debian/changelog
+}