summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2017-08-01 14:02:55 +0300
committerSergey Popov <pinkbyte@gentoo.org>2017-08-01 14:02:55 +0300
commit2e0e1ce1843e4abb1378c109fabe0801babb609d (patch)
tree4425185ba32a3323ae516f043779c7208da7fa4d /x11-misc/dex/dex-0.8.0.ebuild
parentprofiles: Unmask app-emulation/fuse (diff)
downloadgentoo-2e0e1ce1843e4abb1378c109fabe0801babb609d.tar.gz
gentoo-2e0e1ce1843e4abb1378c109fabe0801babb609d.tar.bz2
gentoo-2e0e1ce1843e4abb1378c109fabe0801babb609d.zip
x11-misc/dex: version bump
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'x11-misc/dex/dex-0.8.0.ebuild')
-rw-r--r--x11-misc/dex/dex-0.8.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-misc/dex/dex-0.8.0.ebuild b/x11-misc/dex/dex-0.8.0.ebuild
new file mode 100644
index 000000000000..78866ad5a1d6
--- /dev/null
+++ b/x11-misc/dex/dex-0.8.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit python-r1
+
+DESCRIPTION="DesktopEntry eXecution - tool to manage and launch autostart entries"
+HOMEPAGE="http://e-jc.de/"
+SRC_URI="https://github.com/jceb/dex/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="doc"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx )"
+
+src_compile() {
+ # Makefile is for creating man page only
+ use doc && emake
+}
+
+src_install() {
+ dobin dex
+ python_replicate_script "${ED}/usr/bin/dex"
+ dodoc CHANGELOG.md README.rst
+ use doc && doman dex.1
+}