summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-10-23 11:15:48 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-10-23 11:52:45 +0200
commite50d4491f3048a5b8bb1859433c9430d9d8f6a83 (patch)
tree44aaccdbc5fae04e285b3032be7ce80e0d17d6d9 /x11-misc/copyq
parentdev-libs/dqlite: Disable building of static libraries (diff)
downloadgentoo-e50d4491f3048a5b8bb1859433c9430d9d8f6a83.tar.gz
gentoo-e50d4491f3048a5b8bb1859433c9430d9d8f6a83.tar.bz2
gentoo-e50d4491f3048a5b8bb1859433c9430d9d8f6a83.zip
x11-apps/copyq: [QA] pkgmove to x11-misc/copyq
Non-maintainer commit, PR unusable and no response. Choosing x11-misc for hard-requirement of X11. - Minor style fixes - metadata.xml indentation Closes: https://bugs.gentoo.org/571828 Closes: https://github.com/gentoo/gentoo/pull/16939 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'x11-misc/copyq')
-rw-r--r--x11-misc/copyq/Manifest1
-rw-r--r--x11-misc/copyq/copyq-3.10.0.ebuild59
-rw-r--r--x11-misc/copyq/metadata.xml18
3 files changed, 78 insertions, 0 deletions
diff --git a/x11-misc/copyq/Manifest b/x11-misc/copyq/Manifest
new file mode 100644
index 000000000000..86696b31c9d5
--- /dev/null
+++ b/x11-misc/copyq/Manifest
@@ -0,0 +1 @@
+DIST CopyQ-3.10.0.tar.gz 2832904 BLAKE2B 78866a3ecbd1ed4d1ab06db552ef517234c1354609ef2bc18f8c4d8fa22342c7479a5bde79b9333f896dee4fe18543e47657c780b821f45121e0413c597b45aa SHA512 6cae338a144d7f92850ce88c991ed99222613c57540ced49dab719e43af884bbd9d15e6e8f074c6af94b0ac2ecd1b355eff8b83ec99f688c0f93fa19f253d653
diff --git a/x11-misc/copyq/copyq-3.10.0.ebuild b/x11-misc/copyq/copyq-3.10.0.ebuild
new file mode 100644
index 000000000000..5f4c4eff390c
--- /dev/null
+++ b/x11-misc/copyq/copyq-3.10.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P=CopyQ-${PV}
+inherit cmake xdg-utils
+
+DESCRIPTION="Clipboard manager with advanced features"
+HOMEPAGE="https://github.com/hluk/CopyQ"
+SRC_URI="https://github.com/hluk/CopyQ/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test webkit"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtscript:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ x11-libs/libX11
+ x11-libs/libXfixes
+ x11-libs/libXtst
+ webkit? ( dev-qt/qtwebkit:5 )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-qt/qttest:5 )"
+BDEPEND="dev-qt/linguist-tools:5"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ # CMakeLists.txt concatenates INSTALL_PREFIX with INSTALL_MANDIR leading to /usr/usr
+ local mycmakeargs=(
+ -DPLUGIN_INSTALL_PREFIX="/usr/$(get_libdir)/${PN}/plugins"
+ -DWITH_QT5=ON
+ -DWITH_TESTS=$(usex test)
+ -DWITH_WEBKIT=$(usex webkit)
+ -DCMAKE_INSTALL_MANDIR="share/man"
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
diff --git a/x11-misc/copyq/metadata.xml b/x11-misc/copyq/metadata.xml
new file mode 100644
index 000000000000..967643d46809
--- /dev/null
+++ b/x11-misc/copyq/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>onigino@protonmail.com</email>
+ <name>Gino</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <use>
+ <flag name="webkit">Use advanced HTML rendering and fetching remote images and other data</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">hluk/CopyQ</remote-id>
+ </upstream>
+</pkgmetadata>