summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-libs/libXaw
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-libs/libXaw')
-rw-r--r--x11-libs/libXaw/Manifest2
-rw-r--r--x11-libs/libXaw/files/libXaw-1.0.12-format-security.patch26
-rw-r--r--x11-libs/libXaw/libXaw-1.0.12.ebuild38
-rw-r--r--x11-libs/libXaw/libXaw-1.0.13.ebuild33
-rw-r--r--x11-libs/libXaw/metadata.xml8
5 files changed, 107 insertions, 0 deletions
diff --git a/x11-libs/libXaw/Manifest b/x11-libs/libXaw/Manifest
new file mode 100644
index 000000000000..54ccb30905c9
--- /dev/null
+++ b/x11-libs/libXaw/Manifest
@@ -0,0 +1,2 @@
+DIST libXaw-1.0.12.tar.bz2 677147 SHA256 96fc314874fce9979556321d1d6ee00b5baf32fb333b7278853b4983bc3cdbf6 SHA512 baf11625a20b89f08747e25dff6755ab796c8a5a91341d3cb21f85780733c4a3c25bbf134ac6259982207067d0a617f83f516c48aef6f57cbab14c8a9862944d WHIRLPOOL f23798a3c221d6f23de9b8d708f5c054d39d6681df23a53ab7a3c221215dfafc23463475e2d8290d609fd591443e35c1d0e9bc939a528eca3c6e757d7dd2d6e0
+DIST libXaw-1.0.13.tar.bz2 674140 SHA256 8ef8067312571292ccc2bbe94c41109dcf022ea5a4ec71656a83d8cce9edb0cd SHA512 d768a39f7111802493fa1df1b80d858e4139ceeb883d45ff13ce3b7a0e775a7d2834b7ad157c8330117f04c32f38979795332dd7a119adb2344fcb1aa9cf1e2f WHIRLPOOL c2af8386b8803b0429bc27875761214a5dbabf4b3feda69af18ddcd00ae6809a3de6fa0912ac1299cbb381d4d8180d1a57f2330639bfede79ef9bcbdd6e6fd34
diff --git a/x11-libs/libXaw/files/libXaw-1.0.12-format-security.patch b/x11-libs/libXaw/files/libXaw-1.0.12-format-security.patch
new file mode 100644
index 000000000000..dfc2e23672f9
--- /dev/null
+++ b/x11-libs/libXaw/files/libXaw-1.0.12-format-security.patch
@@ -0,0 +1,26 @@
+From ec7d7c303385a6bdb0833a5aaae96be697cca7ab Mon Sep 17 00:00:00 2001
+From: Adam Jackson <ajax@redhat.com>
+Date: Thu, 21 Nov 2013 11:43:55 -0500
+Subject: Fix build with gcc -Werror=format-security
+
+DisplayList.c:290:4: error: format not a string literal and no format
+arguments [-Werror=format-security]
+
+Signed-off-by: Adam Jackson <ajax@redhat.com>
+
+diff --git a/src/DisplayList.c b/src/DisplayList.c
+index 3e99df4..0581bf7 100644
+--- a/src/DisplayList.c
++++ b/src/DisplayList.c
+@@ -287,7 +287,7 @@ _XawDisplayList *XawCreateDisplayList(String string, Screen *screen,
+ }
+ if (fp)
+ {
+- snprintf(cname, fp - fname + 1, fname);
++ snprintf(cname, fp - fname + 1, "%s", fname);
+ memmove(fname, fp + 1, strlen(fp));
+ lc = cname[0] ? XawGetDisplayListClass(cname) : xlibc;
+ if (!lc)
+--
+cgit v0.10.2
+
diff --git a/x11-libs/libXaw/libXaw-1.0.12.ebuild b/x11-libs/libXaw/libXaw-1.0.12.ebuild
new file mode 100644
index 000000000000..2207503b2b86
--- /dev/null
+++ b/x11-libs/libXaw/libXaw-1.0.12.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit xorg-2
+
+DESCRIPTION="X.Org Xaw library"
+
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="deprecated"
+
+RDEPEND=">=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}]
+ >=x11-libs/libXmu-1.1.1-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXpm-3.5.10-r1[${MULTILIB_USEDEP}]
+ >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}]
+ >=x11-proto/xextproto-7.2.1-r1[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ # Fix build with gcc -Werror=format-security (from 'master')
+ "${FILESDIR}"/${P}-format-security.patch
+)
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable deprecated xaw6)
+ $(use_enable doc specs)
+ $(use_with doc xmlto)
+ --without-fop
+ )
+ xorg-2_src_configure
+}
diff --git a/x11-libs/libXaw/libXaw-1.0.13.ebuild b/x11-libs/libXaw/libXaw-1.0.13.ebuild
new file mode 100644
index 000000000000..2ef33695333f
--- /dev/null
+++ b/x11-libs/libXaw/libXaw-1.0.13.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit xorg-2
+
+DESCRIPTION="X.Org Xaw library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="deprecated"
+
+RDEPEND=">=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}]
+ >=x11-libs/libXmu-1.1.1-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXpm-3.5.10-r1[${MULTILIB_USEDEP}]
+ >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}]
+ >=x11-proto/xextproto-7.2.1-r1[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable deprecated xaw6)
+ $(use_enable doc specs)
+ $(use_with doc xmlto)
+ --without-fop
+ )
+ xorg-2_src_configure
+}
diff --git a/x11-libs/libXaw/metadata.xml b/x11-libs/libXaw/metadata.xml
new file mode 100644
index 000000000000..f58d351da9d8
--- /dev/null
+++ b/x11-libs/libXaw/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>x11</herd>
+<use>
+ <flag name="deprecated">Install deprecated Xaw6 library.</flag>
+</use>
+</pkgmetadata>