summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-03-16 13:48:35 -0400
committerMatt Turner <mattst88@gentoo.org>2023-03-16 13:49:18 -0400
commit525f5abdb7ad717b136f948f3aad2f77bc139563 (patch)
tree7e437cdcb3ec64e61c5876ac9259641a96f7e208 /x11-libs/libXaw
parentapp-crypt/tpm2-abrmd: Stabilize 3.0.0-r1 ppc64, #894968 (diff)
downloadgentoo-525f5abdb7ad717b136f948f3aad2f77bc139563.tar.gz
gentoo-525f5abdb7ad717b136f948f3aad2f77bc139563.tar.bz2
gentoo-525f5abdb7ad717b136f948f3aad2f77bc139563.zip
x11-libs/libXaw: Version bump to 1.0.15
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/libXaw')
-rw-r--r--x11-libs/libXaw/Manifest1
-rw-r--r--x11-libs/libXaw/libXaw-1.0.15.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/x11-libs/libXaw/Manifest b/x11-libs/libXaw/Manifest
index be038e416ea1..3b3ddc255690 100644
--- a/x11-libs/libXaw/Manifest
+++ b/x11-libs/libXaw/Manifest
@@ -1 +1,2 @@
DIST libXaw-1.0.14.tar.bz2 690994 BLAKE2B 9beaf5ad47b300b3bd57c85ce4c54996db824cb10377472bab8b4ec446458ce162b21e19c4e3ed8d48f10d0bddb695509e73d3274326bdd59916dfbb3c63120e SHA512 29d1c151369523ae6cb418e636b0b7b39ccccc35462a0b394dbeb46d5b6d780badd2eb872a55d9fbba1ee1af034e76c0463f40f8d8a7be2c336d08b3b1bf81d4
+DIST libXaw-1.0.15.tar.xz 589832 BLAKE2B a176b59fbbd7555e7ec2f114a31e9ed804c0ee9e2f7f0efc1ed836caa280947bbe1c66dc4b5155f983a91b649a6303730377b5203d17dcd6af8dfdfa51e7784c SHA512 8edbf280b7b24b9040c291545053c1251d6af7e7f56da43a6065a1848245863eb52bdfc28c2f18dbb6597a4064394a44f4df5d8596a1a467549ccc9ce50a7821
diff --git a/x11-libs/libXaw/libXaw-1.0.15.ebuild b/x11-libs/libXaw/libXaw-1.0.15.ebuild
new file mode 100644
index 000000000000..9cd7d07a7490
--- /dev/null
+++ b/x11-libs/libXaw/libXaw-1.0.15.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="X.Org Xaw library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="deprecated"
+
+RDEPEND="x11-base/xorg-proto
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXmu-1.1.1-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXpm-3.5.10-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_enable deprecated xaw6)
+ $(use_enable doc specs)
+ $(use_with doc xmlto)
+ --without-fop
+ )
+ xorg-3_src_configure
+}