summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-12-13 23:11:04 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-12-13 23:19:21 -0500
commit506b573904bef9eae78e4bf46448eccd42564d0f (patch)
treeb3024f5be0d7f00fe23fa145d87c2d6ddbcfbb66 /x11-drivers
parentsci-mathematics/flint: fix C23 build, switch back to autotools (diff)
downloadgentoo-506b573904bef9eae78e4bf46448eccd42564d0f.tar.gz
gentoo-506b573904bef9eae78e4bf46448eccd42564d0f.tar.bz2
gentoo-506b573904bef9eae78e4bf46448eccd42564d0f.zip
x11-drivers/nvidia-drivers: update DRM_*_HELPERS error text
I915 now selects TTM in newer kernels making it usable, however the text is unaware of changes and versions, so just drop the mention that I915 is not usable and suggest checking the kernel's help. Also list QXL example first, it's smaller to build. Still keep AMDGPU listed mostly because it's more recognizable by users. Leaving 535 as-is, last I know of TTM_HELPERS doesn't matter for it and it likely does not have that long of support. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-550.135.ebuild8
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-550.40.82.ebuild8
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-565.77.ebuild8
3 files changed, 12 insertions, 12 deletions
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-550.135.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-550.135.ebuild
index c1a0d5521864..da413e81b3df 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-550.135.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-550.135.ebuild
@@ -118,15 +118,15 @@ pkg_setup() {
use kernel-open && CONFIG_CHECK+=" MMU_NOTIFIER" #843827
local drm_helper_msg="Cannot be directly selected in the kernel's config menus, and may need
- selection of a DRM device even if unused, e.g. CONFIG_DRM_AMDGPU=m or
- DRM_QXL=m, DRM_NOUVEAU=m also acceptable if a module and *not* built-in."
+ selection of a DRM device even if unused, e.g. CONFIG_DRM_QXL=m or
+ DRM_AMDGPU=m (among others, consult the kernel config's help), can
+ also use DRM_NOUVEAU=m as long as built as module *not* built-in."
local ERROR_DRM_KMS_HELPER="CONFIG_DRM_KMS_HELPER: is not set but needed for Xorg auto-detection
of drivers (no custom config), and for wayland / nvidia-drm.modeset=1.
${drm_helper_msg}"
local ERROR_DRM_TTM_HELPER="CONFIG_DRM_TTM_HELPER: is not set but is needed to compile when using
kernel version 6.11.x or newer while DRM_FBDEV_EMULATION is set.
- ${drm_helper_msg}
- Many DRM devices like DRM_I915 cannot currently be used to enable this."
+ ${drm_helper_msg}"
local ERROR_MMU_NOTIFIER="CONFIG_MMU_NOTIFIER: is not set but needed to build with USE=kernel-open.
Cannot be directly selected in the kernel's menuconfig, and may need
selection of another option that requires it such as CONFIG_KVM."
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-550.40.82.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-550.40.82.ebuild
index aff518c359eb..361201aabc83 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-550.40.82.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-550.40.82.ebuild
@@ -120,15 +120,15 @@ pkg_setup() {
use kernel-open && CONFIG_CHECK+=" MMU_NOTIFIER" #843827
local drm_helper_msg="Cannot be directly selected in the kernel's config menus, and may need
- selection of a DRM device even if unused, e.g. CONFIG_DRM_AMDGPU=m or
- DRM_QXL=m, DRM_NOUVEAU=m also acceptable if a module and *not* built-in."
+ selection of a DRM device even if unused, e.g. CONFIG_DRM_QXL=m or
+ DRM_AMDGPU=m (among others, consult the kernel config's help), can
+ also use DRM_NOUVEAU=m as long as built as module *not* built-in."
local ERROR_DRM_KMS_HELPER="CONFIG_DRM_KMS_HELPER: is not set but needed for Xorg auto-detection
of drivers (no custom config), and for wayland / nvidia-drm.modeset=1.
${drm_helper_msg}"
local ERROR_DRM_TTM_HELPER="CONFIG_DRM_TTM_HELPER: is not set but is needed to compile when using
kernel version 6.11.x or newer while DRM_FBDEV_EMULATION is set.
- ${drm_helper_msg}
- Many DRM devices like DRM_I915 cannot currently be used to enable this."
+ ${drm_helper_msg}"
local ERROR_MMU_NOTIFIER="CONFIG_MMU_NOTIFIER: is not set but needed to build with USE=kernel-open.
Cannot be directly selected in the kernel's menuconfig, and may need
selection of another option that requires it such as CONFIG_KVM."
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-565.77.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-565.77.ebuild
index f95de3f867f4..c535351b09c5 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-565.77.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-565.77.ebuild
@@ -122,15 +122,15 @@ pkg_setup() {
use kernel-open && CONFIG_CHECK+=" MMU_NOTIFIER" #843827
local drm_helper_msg="Cannot be directly selected in the kernel's config menus, and may need
- selection of a DRM device even if unused, e.g. CONFIG_DRM_AMDGPU=m or
- DRM_QXL=m, DRM_NOUVEAU=m also acceptable if a module and *not* built-in."
+ selection of a DRM device even if unused, e.g. CONFIG_DRM_QXL=m or
+ DRM_AMDGPU=m (among others, consult the kernel config's help), can
+ also use DRM_NOUVEAU=m as long as built as module *not* built-in."
local ERROR_DRM_KMS_HELPER="CONFIG_DRM_KMS_HELPER: is not set but needed for Xorg auto-detection
of drivers (no custom config), and for wayland / nvidia-drm.modeset=1.
${drm_helper_msg}"
local ERROR_DRM_TTM_HELPER="CONFIG_DRM_TTM_HELPER: is not set but is needed to compile when using
kernel version 6.11.x or newer while DRM_FBDEV_EMULATION is set.
- ${drm_helper_msg}
- Many DRM devices like DRM_I915 cannot currently be used to enable this."
+ ${drm_helper_msg}"
local ERROR_MMU_NOTIFIER="CONFIG_MMU_NOTIFIER: is not set but needed to build with USE=kernel-open.
Cannot be directly selected in the kernel's menuconfig, and may need
selection of another option that requires it such as CONFIG_KVM."