summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-04-05 17:46:43 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-04-05 17:51:13 +0200
commitafb0cfa28426a29b47999ebe41263544b36a010a (patch)
treeaedba6413f24b8f792286f86d0a7c15b35234d36 /www-misc
parentx11-drivers/nvidia-drivers: extend unsupported card warning (diff)
downloadgentoo-afb0cfa28426a29b47999ebe41263544b36a010a.tar.gz
gentoo-afb0cfa28426a29b47999ebe41263544b36a010a.tar.bz2
gentoo-afb0cfa28426a29b47999ebe41263544b36a010a.zip
www-misc/logswan: new package; add 2.1.14
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'www-misc')
-rw-r--r--www-misc/logswan/Manifest1
-rw-r--r--www-misc/logswan/logswan-2.1.14.ebuild28
-rw-r--r--www-misc/logswan/logswan-9999.ebuild28
-rw-r--r--www-misc/logswan/metadata.xml24
4 files changed, 81 insertions, 0 deletions
diff --git a/www-misc/logswan/Manifest b/www-misc/logswan/Manifest
new file mode 100644
index 000000000000..6c69d4321b33
--- /dev/null
+++ b/www-misc/logswan/Manifest
@@ -0,0 +1 @@
+DIST logswan-2.1.14.tar.gz 25223 BLAKE2B d1c18eac839cadeb9486ef032954e271616483aa69419db0d24c7abf0f70e008e9f4ed6f0b054bd1b65d7277ddf923cb7d30c4caa92a6ab4226d5db3df7b99dc SHA512 1956d65088e9cc41d981e47ce487996d0e2e0bf1666f871d59f9f91770666aac90840e4a5b88581f8c2da91ef953ad0e8e4856e088fa86546d74afb8f6ed8b77
diff --git a/www-misc/logswan/logswan-2.1.14.ebuild b/www-misc/logswan/logswan-2.1.14.ebuild
new file mode 100644
index 000000000000..6ac9fe8874df
--- /dev/null
+++ b/www-misc/logswan/logswan-2.1.14.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Fast Web log analyzer using probabilistic data structures"
+HOMEPAGE="https://www.logswan.org/
+ https://github.com/fcambus/logswan/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/fcambus/${PN}.git"
+else
+ SRC_URI="https://github.com/fcambus/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+
+RDEPEND="
+ dev-libs/jansson:=
+ dev-libs/libmaxminddb:=
+"
+DEPEND="${RDEPEND}"
diff --git a/www-misc/logswan/logswan-9999.ebuild b/www-misc/logswan/logswan-9999.ebuild
new file mode 100644
index 000000000000..6ac9fe8874df
--- /dev/null
+++ b/www-misc/logswan/logswan-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Fast Web log analyzer using probabilistic data structures"
+HOMEPAGE="https://www.logswan.org/
+ https://github.com/fcambus/logswan/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/fcambus/${PN}.git"
+else
+ SRC_URI="https://github.com/fcambus/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+
+RDEPEND="
+ dev-libs/jansson:=
+ dev-libs/libmaxminddb:=
+"
+DEPEND="${RDEPEND}"
diff --git a/www-misc/logswan/metadata.xml b/www-misc/logswan/metadata.xml
new file mode 100644
index 000000000000..1642e2f30440
--- /dev/null
+++ b/www-misc/logswan/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription>
+ Logswan is a fast Web log analyzer using probabilistic data structures. It
+ is targeted at very large log files, typically APIs logs. It has constant
+ memory usage regardless of the log file size, and takes approximatively 4MB
+ of RAM. Unique visitors counting is performed using two HyperLogLog
+ counters (one for IPv4, and another one for IPv6), providing a relative
+ accuracy of 0.10%. String representations of IP addresses are used and
+ preferred as they offer better precision. Project design goals include:
+ speed, memory-usage efficiency, and keeping the code as simple as possible.
+ </longdescription>
+ <upstream>
+ <changelog>https://raw.githubusercontent.com/fcambus/logswan/master/ChangeLog</changelog>
+ <bugs-to>https://github.com/fcambus/logswan/issues/</bugs-to>
+ <remote-id type="github">fcambus/logswan</remote-id>
+ </upstream>
+</pkgmetadata>