summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-15 02:30:24 +0000
committerSam James <sam@gentoo.org>2022-12-15 02:30:24 +0000
commita0872bdcc2a6858cc12fd0dd9116c60453a76f2b (patch)
tree203b540379e30806fbf30e04d6697e817abaa334 /www-client/microsoft-edge-beta
parentwww-plugins/chrome-binary-plugins: automated update (109.0.5414.46_beta) (diff)
downloadgentoo-a0872bdcc2a6858cc12fd0dd9116c60453a76f2b.tar.gz
gentoo-a0872bdcc2a6858cc12fd0dd9116c60453a76f2b.tar.bz2
gentoo-a0872bdcc2a6858cc12fd0dd9116c60453a76f2b.zip
www-client/microsoft-edge-beta: automated bump (109.0.1518.23)
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-client/microsoft-edge-beta')
-rw-r--r--www-client/microsoft-edge-beta/Manifest1
-rw-r--r--www-client/microsoft-edge-beta/microsoft-edge-beta-109.0.1518.23.ebuild117
2 files changed, 118 insertions, 0 deletions
diff --git a/www-client/microsoft-edge-beta/Manifest b/www-client/microsoft-edge-beta/Manifest
index 0c3be9aadeab..2b8e26929e7c 100644
--- a/www-client/microsoft-edge-beta/Manifest
+++ b/www-client/microsoft-edge-beta/Manifest
@@ -1,3 +1,4 @@
DIST microsoft-edge-beta_108.0.1462.38-1_amd64.deb 137677858 BLAKE2B b85047109ef5aa1c5eb22d63bcd4deac09b527235ce5e51e3909b246820128af9e6208092c8c4db2b784ce06e8673ebbcb2ce4c23de842bc4d4d96610bda63a5 SHA512 7b56a3e0abbafd1e0a6769f9353832c5e8e250ae57686cb256e06dfc00c2aa0fe8b4ff7ab09127db901ba66fb3db79bd67a6fca150d21ec37f99bcf283674bc3
DIST microsoft-edge-beta_108.0.1462.42-1_amd64.deb 137641730 BLAKE2B 289a3be765702b4ca18ff9c6a7da04e47f3052e6a7e32953d0c28b5ddd67f6828d2dd6e52df641e092f793eb454e7f430d3eb5853ada9b5bea8102848c613320 SHA512 c423f106ecab2119ca6fd92c04f14ff18291932dd30987138e5be2b9f1de123155e99d2a1c50aff6470dc60dd9a99120162948b71214bea65e6fede5aa5b5ec9
DIST microsoft-edge-beta_109.0.1518.14-1_amd64.deb 138900842 BLAKE2B e7909860f332972cdd75b98e409599359f5013031407263cb52ccf241d171738b9531b4c14220f84d901a73225f2cb6ce3366a23104267c3ba4ebd330d20cbb9 SHA512 45688438f556f7c3662f6751395e18ba8d662063dd0f632c41d662d7488a7298887d1cd105be23479d1c5650e03b19536d9b32e7d51601b3c324467e57c603c4
+DIST microsoft-edge-beta_109.0.1518.23-1_amd64.deb 139093622 BLAKE2B c30674e1b6d44f2b0c4f9dae6b49ded150c75da1e049fb93755dec18ca6c2321a7004eb9284115d43e7de90f91dfafd0094d6de96d6251ccd38c60c113569c27 SHA512 b3f13a5be1607a2c50a0bf7216d02e256fbcff32a86bbc8735f73f8e3dd361aed01b2187663af6153832b19dc05c1472db209bd64954165c6a38deec4bef355f
diff --git a/www-client/microsoft-edge-beta/microsoft-edge-beta-109.0.1518.23.ebuild b/www-client/microsoft-edge-beta/microsoft-edge-beta-109.0.1518.23.ebuild
new file mode 100644
index 000000000000..873f8ce87360
--- /dev/null
+++ b/www-client/microsoft-edge-beta/microsoft-edge-beta-109.0.1518.23.ebuild
@@ -0,0 +1,117 @@
+# Copyright 2011-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit chromium-2 desktop pax-utils unpacker xdg
+
+DESCRIPTION="The web browser from Microsoft"
+HOMEPAGE="https://www.microsoft.com/en-us/edge"
+
+if [[ ${PN} == microsoft-edge ]]; then
+ MY_PN=${PN}-stable
+else
+ MY_PN=${PN}
+fi
+
+KEYWORDS="-* ~amd64"
+
+MY_P="${MY_PN}_${PV}-1"
+
+SRC_URI="https://packages.microsoft.com/repos/edge/pool/main/m/${MY_PN}/${MY_P}_amd64.deb"
+
+LICENSE="microsoft-edge"
+SLOT="0"
+RESTRICT="bindist mirror strip"
+IUSE="+mip"
+
+RDEPEND="
+ || (
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ ( app-accessibility/at-spi2-atk dev-libs/atk )
+ )
+ app-misc/ca-certificates
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-fonts/liberation-fonts
+ media-libs/alsa-lib
+ media-libs/mesa[gbm(+)]
+ net-misc/curl[ssl]
+ net-print/cups
+ sys-apps/dbus
+ sys-apps/util-linux
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3[X]
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libxcb
+ x11-libs/libxkbcommon
+ x11-libs/libxshmfence
+ x11-libs/pango
+ x11-misc/xdg-utils
+ mip? ( app-crypt/libsecret )
+"
+
+QA_PREBUILT="*"
+QA_DESKTOP_FILE="usr/share/applications/microsoft-edge.*\\.desktop"
+S=${WORKDIR}
+EDGE_HOME="opt/microsoft/msedge${PN#microsoft-edge}"
+
+pkg_nofetch() {
+ eerror "Please wait 24 hours and sync your tree before reporting a bug for microsoft-edge fetch failures."
+}
+
+pkg_pretend() {
+ # Protect against people using autounmask overzealously
+ use amd64 || die "microsoft-edge only works on amd64"
+}
+
+pkg_setup() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_unpack() {
+ :
+}
+
+src_install() {
+ dodir /
+ cd "${ED}" || die
+ unpacker
+
+ rm -f _gpgorigin || die
+
+ rm -r etc usr/share/menu || die
+ mv usr/share/doc/${MY_PN} usr/share/doc/${PF} || die
+
+ gzip -d usr/share/doc/${PF}/changelog.gz || die
+ gzip -d usr/share/man/man1/${MY_PN}.1.gz || die
+ if [[ -L usr/share/man/man1/${PN}.1.gz ]]; then
+ rm usr/share/man/man1/${PN}.1.gz || die
+ dosym ${MY_PN}.1 usr/share/man/man1/${PN}.1
+ fi
+
+ local suffix=
+ [[ ${PN} == microsoft-edge-beta ]] && suffix=_beta
+ [[ ${PN} == microsoft-edge-dev ]] && suffix=_dev
+
+ local size
+ for size in 16 24 32 48 64 128 256 ; do
+ newicon -s ${size} "${EDGE_HOME}/product_logo_${size}${suffix}.png" ${PN}.png
+ done
+
+ if ! use mip; then
+ rm "${EDGE_HOME}"/libmip_{core,protection_sdk}.so || die
+ fi
+
+ pax-mark m "${EDGE_HOME}/msedge"
+}