summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apps/webmcp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apps/webmcp')
-rw-r--r--www-apps/webmcp/Manifest2
-rw-r--r--www-apps/webmcp/files/webmcp-1.2.5-gentoo.patch141
-rw-r--r--www-apps/webmcp/files/webmcp-1.2.6-gentoo.patch143
-rw-r--r--www-apps/webmcp/metadata.xml11
-rw-r--r--www-apps/webmcp/webmcp-1.2.5.ebuild66
-rw-r--r--www-apps/webmcp/webmcp-1.2.6.ebuild66
6 files changed, 429 insertions, 0 deletions
diff --git a/www-apps/webmcp/Manifest b/www-apps/webmcp/Manifest
new file mode 100644
index 000000000000..f69faf615579
--- /dev/null
+++ b/www-apps/webmcp/Manifest
@@ -0,0 +1,2 @@
+DIST webmcp-v1.2.5.tar.gz 131003 SHA256 16bf5096f4754d56a6f7e059963cd8bc759c406ab50812e49252d97007666da3 SHA512 40ce2f48c0e7362b7cb7a20a44c19d597fd919d98dbd2865aa6c1b5f9c41f593aee408309cf530a7cd0f94e2976ddda93816e723228a7285e689f13e31135589 WHIRLPOOL 51ae7aa7964da773e912ec58ac9113e51a573e6fbde4d01fac63acaaecfcf15f126164321390bf240c23baa99fe7e7e0b1f0ba2c25d70d465395c7c90c9e7432
+DIST webmcp-v1.2.6.tar.gz 132283 SHA256 a8fb516b638fab8cd50e3f9c325c7d166da2f03f3772f9678a47f68ada9f80fe SHA512 a233c312f85851c690f9b020e5df1fffb548c708199279021f384a36cf6e2b73a9b7bc2343c886ccc0e18aecf6d205e2a699fa2398b9bf0da587bc4f8a8f8556 WHIRLPOOL db147e55d7ff327269a112e6df28cbef8ea4398246e790619c577c2df3535bff7f8dfe27587a999c1fef53da7f6438ac2a90881960575b70fdc56b541c716339
diff --git a/www-apps/webmcp/files/webmcp-1.2.5-gentoo.patch b/www-apps/webmcp/files/webmcp-1.2.5-gentoo.patch
new file mode 100644
index 000000000000..2cd506583e6b
--- /dev/null
+++ b/www-apps/webmcp/files/webmcp-1.2.5-gentoo.patch
@@ -0,0 +1,141 @@
+--- Makefile.old 2013-03-12 21:49:03.976676966 +0100
++++ Makefile 2013-03-12 21:50:02.888103540 +0100
+@@ -1,11 +1,11 @@
+ include Makefile.options
+
+ all::
+- make documentation
+- make accelerator
+- make libraries
+- make symlinks
+- make precompile
++ $(MAKE) documentation
++ $(MAKE) accelerator
++ $(MAKE) libraries
++ $(MAKE) symlinks
++ $(MAKE) precompile
+
+ documentation::
+ rm -f doc/autodoc.tmp
+@@ -14,12 +14,12 @@
+ rm -f doc/autodoc.tmp
+
+ accelerator::
+- cd framework/accelerator; make
++ $(MAKE) -C framework/accelerator
+
+ libraries::
+- cd libraries/extos; make
+- cd libraries/mondelefant; make
+- cd libraries/multirand; make
++ $(MAKE) -C libraries/extos
++ $(MAKE) -C libraries/mondelefant
++ $(MAKE) -C libraries/multirand
+
+ symlinks::
+ ln -s -f ../../libraries/atom/atom.lua framework/lib/
+--- Makefile.options.old 2013-03-12 21:54:27.245530485 +0100
++++ Makefile.options 2013-03-12 21:55:45.756768247 +0100
+@@ -10,13 +8,13 @@
+ # C compiler flags
+ # TODO: check alternatives to -D_GNU_SOURCE -fPIC
+ # using libtool?
+-CFLAGS = -O2 -D_GNU_SOURCE -fPIC -Wall -I /usr/include -I /usr/local/include
++CPPFLAGS = -D_GNU_SOURCE
+
+ # additional C compiler flags for parts which depend on PostgreSQL
+ CFLAGS_PGSQL = -I /usr/include/postgresql -I /usr/include/postgresql/server -I /usr/local/include/postgresql -I /usr/local/include/postgresql/server
+
+ # linker flags
+-LDFLAGS = -shared -L /usr/lib -L /usr/local/lib
++LDFLAGS += -shared
+
+ # additional linker flags for parts which depend on PostgreSQL
+ LDFLAGS_PGSQL =
+--- libraries/extos/Makefile.old 2013-03-13 21:49:19.710360750 +0100
++++ libraries/extos/Makefile 2013-03-13 21:49:47.778096460 +0100
+@@ -1,7 +1,7 @@
+ include ../../Makefile.options
+
+ extos.so: extos.o
+- $(LD) $(LDFLAGS) -lrt -lcrypt -o extos.$(SLIB_EXT) extos.o
++ $(LD) $(LDFLAGS) -o extos.$(SLIB_EXT) extos.o -lrt -lcrypt -llua
+
+ extos.o: extos.c
+ $(CC) -c $(CFLAGS) -o extos.o extos.c
+--- libraries/mondelefant/Makefile.old 2013-03-13 21:52:54.884250479 +0100
++++ libraries/mondelefant/Makefile 2013-03-13 21:53:27.511932686 +0100
+@@ -1,7 +1,7 @@
+ include ../../Makefile.options
+
+ mondelefant_native.so: mondelefant_native.o
+- $(LD) $(LDFLAGS) $(LDFLAGS_PGSQL) -o mondelefant_native.$(SLIB_EXT) mondelefant_native.o -lpq
++ $(LD) $(LDFLAGS) $(LDFLAGS_PGSQL) -o mondelefant_native.$(SLIB_EXT) mondelefant_native.o -lpq -llua
+
+ mondelefant_native.o: mondelefant_native.c
+ $(CC) -c $(CFLAGS) $(CFLAGS_PGSQL) -o mondelefant_native.o mondelefant_native.c
+--- libraries/multirand/Makefile.old 2013-03-13 21:54:29.399328173 +0100
++++ libraries/multirand/Makefile 2013-03-13 21:54:58.019048434 +0100
+@@ -1,7 +1,7 @@
+ include ../../Makefile.options
+
+ multirand.so: multirand.o
+- $(LD) $(LDFLAGS) -o multirand.$(SLIB_EXT) multirand.o
++ $(LD) $(LDFLAGS) -o multirand.$(SLIB_EXT) multirand.o -llua
+
+ multirand.o: multirand.c
+ $(CC) -c $(CFLAGS) -o multirand.o multirand.c
+--- libraries/extos/extos.c.old 2013-04-05 23:19:52.028115226 +0200
++++ libraries/extos/extos.c 2013-04-05 23:20:14.819896253 +0200
+@@ -12,6 +12,7 @@
+ #include <fcntl.h>
+ #include <poll.h>
+ #include <stdlib.h>
++#include <crypt.h>
+
+ #define EXTOS_MAX_ERRLEN 80
+ #define EXTOS_EXEC_MAX_ARGS 64
+--- framework/accelerator/Makefile.old 2014-06-21 20:15:21.019918183 +0200
++++ framework/accelerator/Makefile 2014-06-21 20:15:44.700471794 +0200
+@@ -4,7 +4,7 @@
+ $(LD) $(LDFLAGS) -o webmcp_accelerator.$(SLIB_EXT) webmcp_accelerator.o
+
+ webmcp_accelerator.o: webmcp_accelerator.c
+- $(CC) -c $(CFLAGS) -o webmcp_accelerator.o webmcp_accelerator.c
++ $(CC) -c $(CFLAGS) $(CPPFLAGS) -fPIC -o webmcp_accelerator.o webmcp_accelerator.c
+
+ clean::
+ rm -f webmcp_accelerator.so webmcp_accelerator.o
+--- libraries/extos/Makefile.old 2014-06-21 20:18:25.594611956 +0200
++++ libraries/extos/Makefile 2014-06-21 20:18:50.457183029 +0200
+@@ -4,7 +4,7 @@
+ $(LD) $(LDFLAGS) -o extos.$(SLIB_EXT) extos.o -lrt -lcrypt -llua
+
+ extos.o: extos.c
+- $(CC) -c $(CFLAGS) -o extos.o extos.c
++ $(CC) -c $(CFLAGS) $(CPPFLAGS) -fPIC -o extos.o extos.c
+
+ clean::
+ rm -f extos.so extos.o
+--- libraries/mondelefant/Makefile.old 2014-06-21 20:19:58.218962359 +0200
++++ libraries/mondelefant/Makefile 2014-06-21 20:20:24.527476578 +0200
+@@ -4,7 +4,7 @@
+ $(LD) $(LDFLAGS) $(LDFLAGS_PGSQL) -o mondelefant_native.$(SLIB_EXT) mondelefant_native.o -lpq -llua
+
+ mondelefant_native.o: mondelefant_native.c
+- $(CC) -c $(CFLAGS) $(CFLAGS_PGSQL) -o mondelefant_native.o mondelefant_native.c
++ $(CC) -c $(CFLAGS) $(CPPFLAGS) -fPIC $(CFLAGS_PGSQL) -o mondelefant_native.o mondelefant_native.c
+
+ test:: mondelefant_native.so mondelefant.lua
+ lua -l mondelefant
+--- libraries/multirand/Makefile.old 2014-06-21 20:21:36.950197127 +0200
++++ libraries/multirand/Makefile 2014-06-21 20:22:04.967703944 +0200
+@@ -4,7 +4,7 @@
+ $(LD) $(LDFLAGS) -o multirand.$(SLIB_EXT) multirand.o -llua
+
+ multirand.o: multirand.c
+- $(CC) -c $(CFLAGS) -o multirand.o multirand.c
++ $(CC) -c $(CFLAGS) $(CPPFLAGS) -fPIC -o multirand.o multirand.c
+
+ clean::
+ rm -f multirand.so multirand.o
diff --git a/www-apps/webmcp/files/webmcp-1.2.6-gentoo.patch b/www-apps/webmcp/files/webmcp-1.2.6-gentoo.patch
new file mode 100644
index 000000000000..2fa1eb4aff53
--- /dev/null
+++ b/www-apps/webmcp/files/webmcp-1.2.6-gentoo.patch
@@ -0,0 +1,143 @@
+--- Makefile.old 2013-03-12 21:49:03.976676966 +0100
++++ Makefile 2013-03-12 21:50:02.888103540 +0100
+@@ -1,11 +1,11 @@
+ include Makefile.options
+
+ all::
+- make documentation
+- make accelerator
+- make libraries
+- make symlinks
+- make precompile
++ $(MAKE) documentation
++ $(MAKE) accelerator
++ $(MAKE) libraries
++ $(MAKE) symlinks
++ $(MAKE) precompile
+
+ documentation::
+ rm -f doc/autodoc.tmp
+@@ -14,12 +14,12 @@
+ rm -f doc/autodoc.tmp
+
+ accelerator::
+- cd framework/accelerator; make
++ $(MAKE) -C framework/accelerator
+
+ libraries::
+- cd libraries/extos; make
+- cd libraries/mondelefant; make
+- cd libraries/multirand; make
++ $(MAKE) -C libraries/extos
++ $(MAKE) -C libraries/mondelefant
++ $(MAKE) -C libraries/multirand
+
+ symlinks::
+ ln -s -f ../../libraries/atom/atom.lua framework/lib/
+--- Makefile.options.old 2015-05-26 21:43:41.354197822 +0200
++++ Makefile.options 2015-05-26 22:01:34.594735786 +0200
+@@ -14,13 +14,13 @@
+ # C compiler flags
+ # TODO: check alternatives to -D_GNU_SOURCE -fPIC
+ # using libtool?
+-CFLAGS = -O2 -D_GNU_SOURCE -fPIC -Wall -I /usr/include -I /usr/local/include -I /usr/local/include/lua52
++CPPFLAGS = -D_GNU_SOURCE
+
+ # additional C compiler flags for parts which depend on PostgreSQL
+-CFLAGS_PGSQL = -I /usr/local/include/postgresql -I /usr/local/include/postgresql/server
++CFLAGS_PGSQL = -I /usr/include/postgresql -I /usr/include/postgresql/server
+
+ # linker flags
+-LDFLAGS = -shared -L /usr/lib -L /usr/local/lib
++LDFLAGS = -shared
+
+ # additional linker flags for parts which depend on PostgreSQL
+-LDFLAGS_PGSQL = -L /usr/local/lib/postgresql -rpath /usr/local/lib/postgresql
++LDFLAGS_PGSQL =
+--- libraries/extos/Makefile.old 2013-03-13 21:49:19.710360750 +0100
++++ libraries/extos/Makefile 2013-03-13 21:49:47.778096460 +0100
+@@ -1,7 +1,7 @@
+ include ../../Makefile.options
+
+ extos.so: extos.o
+- $(LD) $(LDFLAGS) -lrt -lcrypt -o extos.$(SLIB_EXT) extos.o
++ $(LD) $(LDFLAGS) -o extos.$(SLIB_EXT) extos.o -lrt -lcrypt -llua
+
+ extos.o: extos.c
+ $(CC) -c $(CFLAGS) -o extos.o extos.c
+--- libraries/mondelefant/Makefile.old 2013-03-13 21:52:54.884250479 +0100
++++ libraries/mondelefant/Makefile 2013-03-13 21:53:27.511932686 +0100
+@@ -1,7 +1,7 @@
+ include ../../Makefile.options
+
+ mondelefant_native.so: mondelefant_native.o
+- $(LD) $(LDFLAGS) $(LDFLAGS_PGSQL) -o mondelefant_native.$(SLIB_EXT) mondelefant_native.o -lpq
++ $(LD) $(LDFLAGS) $(LDFLAGS_PGSQL) -o mondelefant_native.$(SLIB_EXT) mondelefant_native.o -lpq -llua
+
+ mondelefant_native.o: mondelefant_native.c
+ $(CC) -c $(CFLAGS) $(CFLAGS_PGSQL) -o mondelefant_native.o mondelefant_native.c
+--- libraries/multirand/Makefile.old 2013-03-13 21:54:29.399328173 +0100
++++ libraries/multirand/Makefile 2013-03-13 21:54:58.019048434 +0100
+@@ -1,7 +1,7 @@
+ include ../../Makefile.options
+
+ multirand.so: multirand.o
+- $(LD) $(LDFLAGS) -o multirand.$(SLIB_EXT) multirand.o
++ $(LD) $(LDFLAGS) -o multirand.$(SLIB_EXT) multirand.o -llua
+
+ multirand.o: multirand.c
+ $(CC) -c $(CFLAGS) -o multirand.o multirand.c
+--- libraries/extos/extos.c.old 2013-04-05 23:19:52.028115226 +0200
++++ libraries/extos/extos.c 2013-04-05 23:20:14.819896253 +0200
+@@ -12,6 +12,7 @@
+ #include <fcntl.h>
+ #include <poll.h>
+ #include <stdlib.h>
++#include <crypt.h>
+
+ #define EXTOS_MAX_ERRLEN 80
+ #define EXTOS_EXEC_MAX_ARGS 64
+--- framework/accelerator/Makefile.old 2014-06-21 20:15:21.019918183 +0200
++++ framework/accelerator/Makefile 2014-06-21 20:15:44.700471794 +0200
+@@ -4,7 +4,7 @@
+ $(LD) $(LDFLAGS) -o webmcp_accelerator.$(SLIB_EXT) webmcp_accelerator.o
+
+ webmcp_accelerator.o: webmcp_accelerator.c
+- $(CC) -c $(CFLAGS) -o webmcp_accelerator.o webmcp_accelerator.c
++ $(CC) -c $(CFLAGS) $(CPPFLAGS) -fPIC -o webmcp_accelerator.o webmcp_accelerator.c
+
+ clean::
+ rm -f webmcp_accelerator.so webmcp_accelerator.o
+--- libraries/extos/Makefile.old 2014-06-21 20:18:25.594611956 +0200
++++ libraries/extos/Makefile 2014-06-21 20:18:50.457183029 +0200
+@@ -4,7 +4,7 @@
+ $(LD) $(LDFLAGS) -o extos.$(SLIB_EXT) extos.o -lrt -lcrypt -llua
+
+ extos.o: extos.c
+- $(CC) -c $(CFLAGS) -o extos.o extos.c
++ $(CC) -c $(CFLAGS) $(CPPFLAGS) -fPIC -o extos.o extos.c
+
+ clean::
+ rm -f extos.so extos.o
+--- libraries/mondelefant/Makefile.old 2014-06-21 20:19:58.218962359 +0200
++++ libraries/mondelefant/Makefile 2014-06-21 20:20:24.527476578 +0200
+@@ -4,7 +4,7 @@
+ $(LD) $(LDFLAGS) $(LDFLAGS_PGSQL) -o mondelefant_native.$(SLIB_EXT) mondelefant_native.o -lpq -llua
+
+ mondelefant_native.o: mondelefant_native.c
+- $(CC) -c $(CFLAGS) $(CFLAGS_PGSQL) -o mondelefant_native.o mondelefant_native.c
++ $(CC) -c $(CFLAGS) $(CPPFLAGS) -fPIC $(CFLAGS_PGSQL) -o mondelefant_native.o mondelefant_native.c
+
+ test:: mondelefant_native.so mondelefant.lua
+ lua -l mondelefant
+--- libraries/multirand/Makefile.old 2014-06-21 20:21:36.950197127 +0200
++++ libraries/multirand/Makefile 2014-06-21 20:22:04.967703944 +0200
+@@ -4,7 +4,7 @@
+ $(LD) $(LDFLAGS) -o multirand.$(SLIB_EXT) multirand.o -llua
+
+ multirand.o: multirand.c
+- $(CC) -c $(CFLAGS) -o multirand.o multirand.c
++ $(CC) -c $(CFLAGS) $(CPPFLAGS) -fPIC -o multirand.o multirand.c
+
+ clean::
+ rm -f multirand.so multirand.o
diff --git a/www-apps/webmcp/metadata.xml b/www-apps/webmcp/metadata.xml
new file mode 100644
index 000000000000..133931e024a5
--- /dev/null
+++ b/www-apps/webmcp/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>tupone@gentoo.org</email>
+<name>Alfredo Tupone</name>
+</maintainer>
+<longdescription lang="en">
+WebMCP is web application framework written in Lua and C. Instead of using the classical Model-View-Controller (MVC) concept, WebMCP makes use of a so-called Model-View-Action concept. The database is accessed through the Model layer, which provides an Object-Relational Mapping (ORM). HTTP-GET requests are handled by Views, which process the request data, query the database, and render the result. HTTP-POST requests are handled by Actions, which can write to the database and redirect to a View, dependent on success or failure.
+</longdescription>
+</pkgmetadata>
diff --git a/www-apps/webmcp/webmcp-1.2.5.ebuild b/www-apps/webmcp/webmcp-1.2.5.ebuild
new file mode 100644
index 000000000000..39ef6cb1e376
--- /dev/null
+++ b/www-apps/webmcp/webmcp-1.2.5.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+MY_P=${PN}-v${PV}
+DESCRIPTION="Web application framework written in Lua and C"
+HOMEPAGE="http://www.public-software-group.org/webmcp"
+SRC_URI="http://www.public-software-group.org/pub/projects/${PN}/v${PV}/${MY_P}.tar.gz"
+
+LICENSE="HPND"
+KEYWORDS="~amd64"
+SLOT=0
+IUSE=""
+
+RDEPEND="dev-lang/lua
+ dev-db/postgresql"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) LD=$(tc-getCC)
+ # Dereference symlinks
+ cd framework
+ mkdir lib.link
+ mv lib/* lib.link
+ cp lib.link/* lib
+}
+
+src_install() {
+ into /usr/lib/${PN}
+ dolib.so framework/lib/*.so
+ for subdir in "" ".precompiled"; do
+ MY_DEST=/usr/lib/${PN}/framework${subdir}
+
+ cd framework${subdir}
+ exeinto ${MY_DEST}/accelerator
+ doexe accelerator/webmcp_accelerator.so
+ insinto ${MY_DEST}
+ doins -r env js
+ exeinto ${MY_DEST}/cgi-bin
+ doexe cgi-bin/webmcp*.lua
+ into ${MY_DEST}
+ dobin bin/*
+ insinto ${MY_DEST}/lib
+ doins lib/*.lua
+ cd ..
+
+ for file in extos.so mondelefant_native.so multirand.so; do
+ dosym ../../$(get_libdir)/$file ${MY_DEST}/lib/$file
+ done
+
+ insinto /usr/share/${PN}
+ doins -r demo-app${subdir}
+ done
+ dodoc doc/*sample.conf libraries/mondelefant/example.lua
+ dohtml doc/autodoc.html
+}
diff --git a/www-apps/webmcp/webmcp-1.2.6.ebuild b/www-apps/webmcp/webmcp-1.2.6.ebuild
new file mode 100644
index 000000000000..115459de2eb2
--- /dev/null
+++ b/www-apps/webmcp/webmcp-1.2.6.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+MY_P=${PN}-v${PV}
+DESCRIPTION="Web application framework written in Lua and C"
+HOMEPAGE="http://www.public-software-group.org/webmcp"
+SRC_URI="http://www.public-software-group.org/pub/projects/${PN}/v${PV}/${MY_P}.tar.gz"
+
+LICENSE="HPND"
+KEYWORDS="~amd64"
+SLOT=0
+IUSE=""
+
+RDEPEND="dev-lang/lua
+ dev-db/postgresql"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) LD=$(tc-getCC)
+ # Dereference symlinks
+ cd framework
+ mkdir lib.link
+ mv lib/* lib.link
+ cp lib.link/* lib
+}
+
+src_install() {
+ into /usr/lib/${PN}
+ dolib.so framework/lib/*.so
+ for subdir in "" ".precompiled"; do
+ MY_DEST=/usr/lib/${PN}/framework${subdir}
+
+ cd framework${subdir}
+ exeinto ${MY_DEST}/accelerator
+ doexe accelerator/webmcp_accelerator.so
+ insinto ${MY_DEST}
+ doins -r env js
+ exeinto ${MY_DEST}/cgi-bin
+ doexe cgi-bin/webmcp*.lua
+ into ${MY_DEST}
+ dobin bin/*
+ insinto ${MY_DEST}/lib
+ doins lib/*.lua
+ cd ..
+
+ for file in extos.so mondelefant_native.so multirand.so; do
+ dosym ../../$(get_libdir)/$file ${MY_DEST}/lib/$file
+ done
+
+ insinto /usr/share/${PN}
+ doins -r demo-app${subdir}
+ done
+ dodoc doc/*sample.conf libraries/mondelefant/example.lua
+ dohtml doc/autodoc.html
+}