summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2024-07-11 10:18:28 -0400
committerCraig Andrews <candrews@gentoo.org>2024-07-11 10:19:30 -0400
commitac90eebb33babdeb04afeeb68bc77b28d386c123 (patch)
tree0b5b5f1e6babd1611227577030ffb3c7b964e104 /www-apache
parentwww-apps/prowlarr-bin: drop 1.20.0.4590 (diff)
downloadgentoo-ac90eebb33babdeb04afeeb68bc77b28d386c123.tar.gz
gentoo-ac90eebb33babdeb04afeeb68bc77b28d386c123.tar.bz2
gentoo-ac90eebb33babdeb04afeeb68bc77b28d386c123.zip
www-apache/mod_h2: add 2.0.29
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_h2/Manifest1
-rw-r--r--www-apache/mod_h2/mod_h2-2.0.29.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/www-apache/mod_h2/Manifest b/www-apache/mod_h2/Manifest
index 1ea7e2b55378..ba73f505f35c 100644
--- a/www-apache/mod_h2/Manifest
+++ b/www-apache/mod_h2/Manifest
@@ -1 +1,2 @@
DIST mod_h2-2.0.27.tar.gz 692514 BLAKE2B c089644fada8fa2293a23d4af60ed23fd795b4ed2df170992ff89c898b663e83ad68080d083d58a5beab3a9e0ddbe56e35c99b8ba3551939bf68570652288abf SHA512 37be31f74bd9c54905c9be84bc7e6bd602604c113c2cb0af2eb9229a010763b04ce508a15a474b9193228ba6d075664879f42600253eb7ed92845285f20141f8
+DIST mod_h2-2.0.29.tar.gz 694725 BLAKE2B b9c7a325ab49feded5ca80881a97aa1b3cbc2ef388a857199027ceec69322890d69fcd2a6859c72e2fd94a77121f9a8fcebb76116375cf699bb8cf8d97804156 SHA512 cd784c5100fcd1b24c05dfce18c8b926d2af3d9e6fe37cecef5f629d1d76105e6c68dba5985007b50cfd8c909ec739126d3e5b2226ac6eef46265806b8aaeaee
diff --git a/www-apache/mod_h2/mod_h2-2.0.29.ebuild b/www-apache/mod_h2/mod_h2-2.0.29.ebuild
new file mode 100644
index 000000000000..dddc92e83e4f
--- /dev/null
+++ b/www-apache/mod_h2/mod_h2-2.0.29.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit apache-module autotools
+
+MY_P="${PN/h2/http2}-${PV}"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/icing/mod_h2.git"
+ inherit git-r3
+else
+ MY_PV="${PV/_rc/-rc}"
+ MY_P="${PN}-${MY_PV}"
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://github.com/icing/mod_h2/archive/v${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="HTTP/2 module for Apache"
+HOMEPAGE="https://github.com/icing/mod_h2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND=">=net-libs/nghttp2-1.0
+ >=www-servers/apache-2.4.48[-apache2_modules_http2,ssl?]"
+DEPEND="${RDEPEND}"
+
+need_apache2_4
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+
+ APACHE2_MOD_DEFINE="HTTP2"
+ insinto "${APACHE_MODULES_CONFDIR}"
+ newins "${FILESDIR}/mod_http2.conf" "41_mod_http2.conf"
+}