summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2024-10-29 15:10:48 +0000
committerJoonas Niilola <juippis@gentoo.org>2024-12-04 20:10:36 +0200
commita5717b1315f0b4c8cb324e8ca78a930432fea29a (patch)
treea5d5f3afb68ac7bebde9faa76762d87110ce1140 /www-apache
parentnet-libs/gtk-vnc: sort deps, add missing dep (diff)
downloadgentoo-a5717b1315f0b4c8cb324e8ca78a930432fea29a.tar.gz
gentoo-a5717b1315f0b4c8cb324e8ca78a930432fea29a.tar.bz2
gentoo-a5717b1315f0b4c8cb324e8ca78a930432fea29a.zip
www-apache/modsecurity-crs: add 4.8.0
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/modsecurity-crs/Manifest1
-rw-r--r--www-apache/modsecurity-crs/modsecurity-crs-4.8.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/www-apache/modsecurity-crs/Manifest b/www-apache/modsecurity-crs/Manifest
index e0d28d994a58..2debe33ea758 100644
--- a/www-apache/modsecurity-crs/Manifest
+++ b/www-apache/modsecurity-crs/Manifest
@@ -2,3 +2,4 @@ DIST modsecurity-crs-3.3.5.tar.gz 299458 BLAKE2B b8617de77cf5168c7b95fab46eae45e
DIST modsecurity-crs-3.3.6.tar.gz 301489 BLAKE2B 8e7b5b3aacd37731b8d83bb6d761454ad48b625e40c8a951a7d6a4ddc9c62efd41cc9c66d74b334d9339f48aa0fe7399e61316edfea6b34b42708084512222ca SHA512 6e5a7b3ceb7d4a8500044425f7439f1967248ff8ab54c4e8d6b4592460afa75d8a7ac973766b58e54cb02cc08559e61fe8689488fc1261b54a8d49933e65bde2
DIST modsecurity-crs-4.0.0.tar.gz 504720 BLAKE2B e6da0268ae9209179d1f6cefba34e097b614dd4659a4b4df2ef3e6a0b32be7be9d825beaf6d8ca1fbef0dd27217b4707090844e59eaa817111be4a6f8333e205 SHA512 c25bfd6de772815977783e78d7afd388d60bbba151762a38c7050fd5ecde6a48baa0a850028a24d42855ae4a788404ad1ee0f7a4ad2d94d53a46e261a00f7224
DIST modsecurity-crs-4.7.0.tar.gz 513616 BLAKE2B c3c25baf0ee5b0508d9c5b55702060023c94f4b794bf00f3be47b0541ca90a9fabda9d3d28a95d4b589e5ac971dfb5b9fba731711db389d2d4dcdab9944d8109 SHA512 13b652768a0ea3c3f5e1cae6bc25d520ef22943faf87564340751374e5df238b17526466cafd452846edfc436f6ad98cdd5ed5496531981c1ebebd2c179d22d7
+DIST modsecurity-crs-4.8.0.tar.gz 486857 BLAKE2B 3951ffcbf44ee01fbe9199655812a448ad0a5a0b02b68f44b4c8fd83f9533edfa96449bcb90c297bd7abfa4bb236951a4b0828b75a14bc9c63033dac48cd4ca2 SHA512 07a35b58da5d614ac3858be46ca7e74dfaceafff1e034d363a31ab522bfda2b80475bf3c73e74cb10e6c7c6345129c034291240315c4dd598aa4bad49c7e82c0
diff --git a/www-apache/modsecurity-crs/modsecurity-crs-4.8.0.ebuild b/www-apache/modsecurity-crs/modsecurity-crs-4.8.0.ebuild
new file mode 100644
index 000000000000..1a0a134d3046
--- /dev/null
+++ b/www-apache/modsecurity-crs/modsecurity-crs-4.8.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+MY_PV=${PV/_/-}
+
+DESCRIPTION="OWASP ModSecurity Core Rule Set"
+HOMEPAGE="https://coreruleset.org/"
+SRC_URI="https://github.com/coreruleset/coreruleset/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/coreruleset-${MY_PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+apache2"
+
+RDEPEND="apache2? ( >=www-apache/mod_security-2.9.6 )"
+
+DOCS=( CHANGES.md CONTRIBUTORS.md crs-setup.conf.example KNOWN_BUGS.md README.md )
+
+src_install() {
+ insinto "/usr/share/${PN}"
+ doins -r plugins rules
+
+ einstalldocs
+
+ if use apache2; then
+ # I don't think it's worth pulling in apache-module.eclass just for
+ # this path...
+ insinto /etc/apache2/modules.d
+ doins "${FILESDIR}/80_mod_security-crs.conf"
+ fi
+}
+
+pkg_postinst() {
+ if use apache2; then
+ einfo "The CRS configuration file has been installed to:"
+ einfo " ${ROOT}/etc/apache2/modules.d/80_mod_security-crs.conf"
+ fi
+
+ optfeature "apache-less installations, e.g. nginx" dev-libs/modsecurity
+}