summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2024-06-07 10:54:11 +0200
committerHanno Böck <hanno@gentoo.org>2024-06-07 10:54:14 +0200
commit1a367ad8d2d63805888c414ee9e26419ede81467 (patch)
tree4813043fc30d8582ed5828d257675b56e0a3a637 /www-apache
parentapp-editors/gvim: Stabilize 9.1.0366 arm, #933697 (diff)
downloadgentoo-1a367ad8d2d63805888c414ee9e26419ede81467.tar.gz
gentoo-1a367ad8d2d63805888c414ee9e26419ede81467.tar.bz2
gentoo-1a367ad8d2d63805888c414ee9e26419ede81467.zip
www-apache/mod_wsgi: add 5.0.0
Support python 3.12, bump EAPI. Closes: https://bugs.gentoo.org/929870 Signed-off-by: Hanno Böck <hanno@gentoo.org>
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_wsgi/Manifest1
-rw-r--r--www-apache/mod_wsgi/mod_wsgi-5.0.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/www-apache/mod_wsgi/Manifest b/www-apache/mod_wsgi/Manifest
index ccb9c85dea5e..b31f959fed6f 100644
--- a/www-apache/mod_wsgi/Manifest
+++ b/www-apache/mod_wsgi/Manifest
@@ -1,2 +1,3 @@
DIST mod_wsgi-4.9.0.tar.gz 699891 BLAKE2B 7ee6ffc28e86baf8ee92973479a26964f7c183c2b113b49a48af02c622f8d8f698abffcd4f522a1ecca5b89325f94856cbe89db5a81d2ac2e87438ee90be97b0 SHA512 9dc34d431171321094a9713444895d9754eff4e69ad1e86c8d3cd77bc1ca0a4c10b697e7f8cf14902d6bfaf205c8842e62fa944bb38f66f1c54fd36af95a09d6
DIST mod_wsgi-4.9.4.gh.tar.gz 706904 BLAKE2B 6473ee5be4f21d7d5806028b22d582e9d2b6f2a28bb0ed2b03a3da799858bdb4ebcfc85eb7850e91ff041d0c0a6cf2a898bffbbe884faa891c4f1f115d043517 SHA512 0898221d95f0ce374cbd34a1849a6e6b5bd7850644d5fe36f558dcc58095cd535c854cb06798482d312485b8d89b8641d91fa26af3d208e10a6073b885af3199
+DIST mod_wsgi-5.0.0.gh.tar.gz 707590 BLAKE2B 14dd43849c0f9d1e67eece9a87acc3573cbb38f8d6338551b22ba33ebd8b6f6e1371e97c7c5d3f1b15cb10e2ae9990eff7f4c6af62fb9236bcc78b35aad4a8db SHA512 3ecc3ad2fd05164929915541be61201db8d35d1e27183ce26c67583b836bb404bd10c88a2ada94714a14140a7f885eb67256cf02bf47aa0dbd81aecd0894a984
diff --git a/www-apache/mod_wsgi/mod_wsgi-5.0.0.ebuild b/www-apache/mod_wsgi/mod_wsgi-5.0.0.ebuild
new file mode 100644
index 000000000000..777e934aadbf
--- /dev/null
+++ b/www-apache/mod_wsgi/mod_wsgi-5.0.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit apache-module python-single-r1
+
+DESCRIPTION="An Apache2 module for running Python WSGI applications"
+HOMEPAGE="https://github.com/GrahamDumpleton/mod_wsgi"
+SRC_URI="https://github.com/GrahamDumpleton/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ppc ~ppc64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+
+APACHE2_MOD_CONF="70_${PN}"
+APACHE2_MOD_DEFINE="WSGI"
+APACHE2_MOD_FILE="${S}/src/server/.libs/${PN}.so"
+
+DOCFILES="README.rst"
+
+need_apache2
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+
+ # Calling depend.apache_pkg_setup fails because we do not have
+ # "apache2" in IUSE but the function expects this in order to call
+ # _init_apache2_late which sets the APACHE_MODULESDIR variable.
+ _init_apache2
+ _init_apache2_late
+}
+
+src_configure() {
+ econf --with-apxs="${APXS}" --with-python="${PYTHON}"
+}
+
+src_compile() {
+ default
+}