summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apache/mod_xsendfile
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apache/mod_xsendfile')
-rw-r--r--www-apache/mod_xsendfile/Manifest1
-rw-r--r--www-apache/mod_xsendfile/files/50_mod_xsendfile.conf20
-rw-r--r--www-apache/mod_xsendfile/metadata.xml18
-rw-r--r--www-apache/mod_xsendfile/mod_xsendfile-1.0_beta1.ebuild28
4 files changed, 67 insertions, 0 deletions
diff --git a/www-apache/mod_xsendfile/Manifest b/www-apache/mod_xsendfile/Manifest
new file mode 100644
index 000000000000..e4fc95a08bb5
--- /dev/null
+++ b/www-apache/mod_xsendfile/Manifest
@@ -0,0 +1 @@
+DIST mod_xsendfile-1.0b1.tar.gz 14883 SHA256 4646d6dfa0d57b2a45a9881dcf932c065e712f68effe649e3c7903b16103f98b SHA512 96745a5c753af329cabc10b1551e199425abf28c058222e118e67c604a53cfebb4fd8e27558caa58269ca8b4ca805ac6c4a71654c8414331c095bd600a4b3914 WHIRLPOOL 7aa9294b02951c1f1c617d497f655fed15c7651c061622012b9a3482bb9f010dee809b63777262e2d3faca2934a3721c5e8128780dcdd6fe96d032ab03cdf846
diff --git a/www-apache/mod_xsendfile/files/50_mod_xsendfile.conf b/www-apache/mod_xsendfile/files/50_mod_xsendfile.conf
new file mode 100644
index 000000000000..eda65879a6ff
--- /dev/null
+++ b/www-apache/mod_xsendfile/files/50_mod_xsendfile.conf
@@ -0,0 +1,20 @@
+<IfDefine XSENDFILE>
+LoadModule xsendfile_module modules/mod_xsendfile.so
+
+# Enables or disables header processing
+# XSendFile on|off
+XSendFile on
+# Ignore script provided Etag headers
+# XSendFileIgnoreEtag on|off
+#
+# Ignore script provided LastModified headers
+# XSendFileIgnoreLastModified on|off
+#
+# White-list more paths
+# XSendFilePath absolute path
+#
+# XSendFilePath /var/infiniband_mount/shared/LUN1/
+#
+</IfDefine>
+
+# vim: ts=4 filetype=apache
diff --git a/www-apache/mod_xsendfile/metadata.xml b/www-apache/mod_xsendfile/metadata.xml
new file mode 100644
index 000000000000..8bca261d7b50
--- /dev/null
+++ b/www-apache/mod_xsendfile/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>andreis.vinogradovs@gmail.com</email>
+ <name>Andreis Vinogradovs</name>
+ </maintainer>
+ <maintainer>
+ <email>maksbotan@gentoo.org</email>
+ <name>Maxim Koltsov</name>
+ </maintainer>
+ <maintainer>
+ <email>qnikst@gentoo.org</email>
+ <name>Alexander Vershilov</name>
+ </maintainer>
+
+</pkgmetadata>
diff --git a/www-apache/mod_xsendfile/mod_xsendfile-1.0_beta1.ebuild b/www-apache/mod_xsendfile/mod_xsendfile-1.0_beta1.ebuild
new file mode 100644
index 000000000000..8911b4ed9321
--- /dev/null
+++ b/www-apache/mod_xsendfile/mod_xsendfile-1.0_beta1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit apache-module
+
+MY_PV="1.0b1"
+DESCRIPTION="Apache2 module that processes X-SENDFILE headers registered by the original output handler"
+HOMEPAGE="https://tn123.org/mod_xsendfile/"
+SRC_URI="https://tn123.org/mod_xsendfile/beta/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 sparc x86 ~amd64-linux"
+IUSE=""
+
+S=${WORKDIR}
+
+RDEPEND="${DEPEND}"
+
+APACHE2_MOD_CONF="50_${PN}"
+APACHE2_MOD_DEFINE="XSENDFILE"
+
+DOCFILES="docs/Readme.html"
+
+need_apache2