summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2020-04-30 21:32:18 +0000
committerThomas Deutschmann <whissi@gentoo.org>2020-06-27 00:59:42 +0200
commit1df35586c28545e4f03a2f7153f8e81201711c8f (patch)
treea2b61c3e7d39792f66aa7a2ff0d6f599585e4c22 /www-apache/mod_maxminddb/mod_maxminddb-1.2.0.ebuild
parentapp-text/libspectre: Get ready for potential ghostscript subslot bumps (diff)
downloadgentoo-1df35586c28545e4f03a2f7153f8e81201711c8f.tar.gz
gentoo-1df35586c28545e4f03a2f7153f8e81201711c8f.tar.bz2
gentoo-1df35586c28545e4f03a2f7153f8e81201711c8f.zip
www-apache/mod_maxminddb: add package
Apache module that allows to interact with maxminddb (geoip2). Closes: https://bugs.gentoo.org/578062 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/15584 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'www-apache/mod_maxminddb/mod_maxminddb-1.2.0.ebuild')
-rw-r--r--www-apache/mod_maxminddb/mod_maxminddb-1.2.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/www-apache/mod_maxminddb/mod_maxminddb-1.2.0.ebuild b/www-apache/mod_maxminddb/mod_maxminddb-1.2.0.ebuild
new file mode 100644
index 000000000000..c0d42244f01a
--- /dev/null
+++ b/www-apache/mod_maxminddb/mod_maxminddb-1.2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit apache-module autotools
+
+DESCRIPTION="MaxMind DB Apache Module"
+HOMEPAGE="https://maxmind.github.io/mod_maxminddb/"
+SRC_URI="https://github.com/maxmind/mod_maxminddb/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-libs/libmaxminddb:="
+RDEPEND="${DEPEND}"
+
+need_apache2_4
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ # skipping this results in:
+ # Cannot load modules/mod_maxminddb.so into server:
+ # /usr/lib64/apache2/modules/mod_maxminddb.so: undefined symbol: MMDB_aget_value
+ # because mod_maxminddb.so is not linked with libmaxminddb
+ emake
+}
+
+src_install() {
+ APACHE2_MOD_CONF="70_${PN}"
+ APACHE2_MOD_DEFINE="MAXMINDDB"
+ APACHE_MODULESDIR="/usr/$(get_libdir)/apache2/modules"
+
+ apache-module_src_install
+}