summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apache/mod_evasive
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apache/mod_evasive')
-rw-r--r--www-apache/mod_evasive/Manifest1
-rw-r--r--www-apache/mod_evasive/files/10_mod_evasive.conf31
-rw-r--r--www-apache/mod_evasive/metadata.xml5
-rw-r--r--www-apache/mod_evasive/mod_evasive-1.10.1-r1.ebuild38
4 files changed, 75 insertions, 0 deletions
diff --git a/www-apache/mod_evasive/Manifest b/www-apache/mod_evasive/Manifest
new file mode 100644
index 000000000000..36a8f676e7e1
--- /dev/null
+++ b/www-apache/mod_evasive/Manifest
@@ -0,0 +1 @@
+DIST mod_evasive_1.10.1.tar.gz 20454 SHA256 07c45139aa313899484a900f0fc162b3e17eb4f60fe474d7f3dd6c9941e95667 SHA512 03b276d1a3dc8e853ca7f3791d66383492a7ae8f3b73988f0eefa7e4e31f267da432e811de81c8d721033e152e94139efc99ad80da809f220a1330e9d43d39ba WHIRLPOOL d461998009eba9c961388b29e504e33d151f7720b84c7151b1b69e25428e55ef8eb1b42edf3bbbc1dcc9b1432760efb80bf45bf1060361d95e4b983e381a17a7
diff --git a/www-apache/mod_evasive/files/10_mod_evasive.conf b/www-apache/mod_evasive/files/10_mod_evasive.conf
new file mode 100644
index 000000000000..31ea08c7bf09
--- /dev/null
+++ b/www-apache/mod_evasive/files/10_mod_evasive.conf
@@ -0,0 +1,31 @@
+<IfDefine EVASIVE>
+LoadModule evasive_module modules/mod_evasive.so
+
+DOSHashTableSize 3097
+DOSPageCount 5
+DOSSiteCount 100
+DOSPageInterval 2
+DOSSiteInterval 2
+DOSBlockingPeriod 10
+
+# Set here an email to notify the DoS to someone
+# (here is better to set the server administrator email)
+DOSEmailNotify root
+
+# Uncomment this line if you want to execute a specific command
+# after the DoS detection
+#DOSSystemCommand "su - someuser -c '/sbin/... %s ...'"
+
+# Specify the desired mod_evasive log location
+DOSLogDir /var/log/apache2/evasive
+
+# WHITELISTING IP ADDRESSES
+# IP addresses of trusted clients can be whitelisted to insure they are never
+# denied. The purpose of whitelisting is to protect software, scripts, local
+# searchbots, or other automated tools from being denied for requesting large
+# amounts of data from the server.
+#DOSWhitelist 127.0.0.*
+#DOSWhitelist 172.16.1.*
+</IfDefine>
+
+# vim: ts=4 filetype=apache
diff --git a/www-apache/mod_evasive/metadata.xml b/www-apache/mod_evasive/metadata.xml
new file mode 100644
index 000000000000..4538a68724a6
--- /dev/null
+++ b/www-apache/mod_evasive/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/www-apache/mod_evasive/mod_evasive-1.10.1-r1.ebuild b/www-apache/mod_evasive/mod_evasive-1.10.1-r1.ebuild
new file mode 100644
index 000000000000..291b67eca674
--- /dev/null
+++ b/www-apache/mod_evasive/mod_evasive-1.10.1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit apache-module eutils
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="mod_evasive is an evasive maneuvers module to provide action in the event of an HTTP DoS"
+HOMEPAGE="http://www.zdziarski.com/blog/?page_id=442"
+SRC_URI="http://www.zdziarski.com/projects/mod_evasive/${P/-/_}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+APACHE2_MOD_CONF="10_${PN}"
+APACHE2_MOD_DEFINE="EVASIVE"
+
+need_apache2_4
+
+S="${WORKDIR}"/${PN}
+
+src_prepare() {
+ # Apache 2.4
+ sed -i -e 's/connection->remote_ip/connection->client_ip/' mod_evasive20.c || die
+ mv ${PN}20.c ${PN}.c
+ sed -i -e 's:evasive20_module:evasive_module:g' ${PN}.c || die
+}
+
+src_install() {
+ keepdir /var/log/apache2/evasive
+ apache-module_src_install
+}