summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-12 17:55:52 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-12 19:38:23 +0100
commit156b9e32ecaf93a5205973fb35dc1a4d56863602 (patch)
tree98884b2302c53211f01db49ee3048562e0d1163e /virtual
parentdev-ml/zarith: bump to 1.4.1 (diff)
downloadgentoo-156b9e32ecaf93a5205973fb35dc1a4d56863602.tar.gz
gentoo-156b9e32ecaf93a5205973fb35dc1a4d56863602.tar.bz2
gentoo-156b9e32ecaf93a5205973fb35dc1a4d56863602.zip
virtual/python-ipaddress: Add new virtual for module with mixed impl support
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'virtual')
-rw-r--r--virtual/python-ipaddress/metadata.xml5
-rw-r--r--virtual/python-ipaddress/python-ipaddress-1.0.ebuild24
2 files changed, 29 insertions, 0 deletions
diff --git a/virtual/python-ipaddress/metadata.xml b/virtual/python-ipaddress/metadata.xml
new file mode 100644
index 000000000000..301d2207cc29
--- /dev/null
+++ b/virtual/python-ipaddress/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+</pkgmetadata>
diff --git a/virtual/python-ipaddress/python-ipaddress-1.0.ebuild b/virtual/python-ipaddress/python-ipaddress-1.0.ebuild
new file mode 100644
index 000000000000..8a6b181c6c5a
--- /dev/null
+++ b/virtual/python-ipaddress/python-ipaddress-1.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit python-r1
+
+DESCRIPTION="A virtual for Python ipaddress module"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/ipaddress[${PYTHON_USEDEP}]' \
+ python2_7 'pypy*')"