summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-06-23 23:46:14 +0100
committerSam James <sam@gentoo.org>2024-06-23 23:46:14 +0100
commitacf4c3b19d2e93a66020970627da22e813747e2a (patch)
tree3ceee86ccef2e022e68649991aad3feedfaee3e7 /sys-process
parentsys-devel/gcc: add 15.0.0_pre20240623 (diff)
downloadgentoo-acf4c3b19d2e93a66020970627da22e813747e2a.tar.gz
gentoo-acf4c3b19d2e93a66020970627da22e813747e2a.tar.bz2
gentoo-acf4c3b19d2e93a66020970627da22e813747e2a.zip
sys-process/audit: fix musl build
Closes: https://bugs.gentoo.org/934006 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/audit/audit-3.1.3.ebuild2
-rw-r--r--sys-process/audit/files/audit-3.1.3-musl-malloc.patch28
2 files changed, 29 insertions, 1 deletions
diff --git a/sys-process/audit/audit-3.1.3.ebuild b/sys-process/audit/audit-3.1.3.ebuild
index a7941a5d6676..e185e4615aae 100644
--- a/sys-process/audit/audit-3.1.3.ebuild
+++ b/sys-process/audit/audit-3.1.3.ebuild
@@ -46,7 +46,7 @@ BDEPEND="
CONFIG_CHECK="~AUDIT"
PATCHES=(
- "${FILESDIR}"/${PN}-3.0.8-musl-malloc.patch
+ "${FILESDIR}"/${PN}-3.1.3-musl-malloc.patch
)
QA_CONFIG_IMPL_DECL_SKIP=(
diff --git a/sys-process/audit/files/audit-3.1.3-musl-malloc.patch b/sys-process/audit/files/audit-3.1.3-musl-malloc.patch
new file mode 100644
index 000000000000..01c440f3eb83
--- /dev/null
+++ b/sys-process/audit/files/audit-3.1.3-musl-malloc.patch
@@ -0,0 +1,28 @@
+https://bugs.gentoo.org/934006
+https://github.com/linux-audit/audit-userspace/commit/1dd6123e810ce255692a693a5d52a0c34cf432d0
+
+From 1dd6123e810ce255692a693a5d52a0c34cf432d0 Mon Sep 17 00:00:00 2001
+From: Steve Grubb <ausearch.1@gmail.com>
+Date: Mon, 1 Apr 2024 12:10:33 -0400
+Subject: [PATCH] Add empty macro to fix muscl c builds
+
+--- a/common/common.h
++++ b/common/common.h
+@@ -1,5 +1,5 @@
+-/* audit-fgets.h -- a replacement for glibc's fgets
+- * Copyright 2018,2022 Red Hat Inc.
++/* common.h -- common utility functions used throughout
++ * Copyright 2018-24 Red Hat Inc.
+ * All Rights Reserved.
+ *
+ * This library is free software; you can redistribute it and/or
+@@ -29,6 +29,9 @@
+ #ifndef __attr_access
+ # define __attr_access(x)
+ #endif
++#ifndef __attribute_malloc__
++# define __attribute_malloc__
++#endif
+ #ifndef __attr_dealloc
+ # define __attr_dealloc(dealloc, argno)
+ #endif