summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-06-21 21:31:16 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-06-21 21:31:16 +0300
commit5072e856ee7a60b2e95bd8f3f9a4511e5df525f8 (patch)
tree77f791e65216b886ec547c215d586154a939f2db /sys-process
parentsys-process/runit: Stabilize 2.1.2-r2 arm64, #934649 (diff)
downloadgentoo-5072e856ee7a60b2e95bd8f3f9a4511e5df525f8.tar.gz
gentoo-5072e856ee7a60b2e95bd8f3f9a4511e5df525f8.tar.bz2
gentoo-5072e856ee7a60b2e95bd8f3f9a4511e5df525f8.zip
sys-process/nmon: add 16q
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/nmon/Manifest1
-rw-r--r--sys-process/nmon/nmon-16q.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/sys-process/nmon/Manifest b/sys-process/nmon/Manifest
index ae5b3e30fb78..c539ea62c331 100644
--- a/sys-process/nmon/Manifest
+++ b/sys-process/nmon/Manifest
@@ -1 +1,2 @@
DIST lmon16n.c 268772 BLAKE2B a85aa30029cff39859058689f013801d864a9ecc0f1115d59aac4b86284108b43c1f4230fdc617c1b7718ed503634ba14dfca2f9a6fb4cb8592e9f6bc327739f SHA512 7b801e3d8a1d60794993af6572b8db04aa0bc707cebd16404c6ad9056f4c37216d57e894241540405192bf76a7e0a49f2e31b55b1721c7eb9da437808ff5abda
+DIST lmon16q.c 271117 BLAKE2B cd1238b0f7c00dc719635231dc38dd091d33608b124d619a0ca5cd2d1b58826d14024c01b4683ca53ecdfbb0efef8185e71cc800cbde7c0a5d43548b26730832 SHA512 06386a4c4b77d029b7cbbbc7f4f8b22028787d286e725257b5daef6d77551c5d3d2c26d303adfab8a953455e51ae308ffb5b1170856ff7b391e696f677bafeef
diff --git a/sys-process/nmon/nmon-16q.ebuild b/sys-process/nmon/nmon-16q.ebuild
new file mode 100644
index 000000000000..3f39fe737fa2
--- /dev/null
+++ b/sys-process/nmon/nmon-16q.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+MY_P="lmon${PV}"
+DESCRIPTION="Nigel's performance MONitor for CPU, memory, network, disks, etc"
+HOMEPAGE="http://nmon.sourceforge.net/"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${MY_P}.c"
+S="${WORKDIR}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="sys-libs/ncurses:="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-16n-musl.patch
+)
+
+src_unpack() {
+ cp "${DISTDIR}"/${MY_P}.c "${S}"/${PN}.c || die
+}
+
+src_configure() {
+ local cflags=(
+ # Recommended by upstream to be always on
+ -DGETUSER
+ -DJFS
+ -DLARGEMEM
+ -DKERNEL_2_6_18
+
+ # Arches
+ $(usex amd64 -DX86 '')
+ $(usex x86 -DX86 '')
+ $(usex arm -DARM '')
+ $(usex ppc64 -DPOWER '')
+ )
+
+ append-cflags "${cflags[@]}"
+ append-libs "$($(tc-getPKG_CONFIG) --libs ncurses) -lm"
+}
+
+src_compile() {
+ tc-export CC
+
+ emake ${PN} LDLIBS="${LIBS}"
+}
+
+src_install() {
+ dobin ${PN}
+}