summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-10 13:44:56 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-10 14:58:40 +0200
commit4c0df1554143725d5059079b9938f0cdab1350d1 (patch)
tree3f9df2401ed8215442d250b019f2a020f290f039 /sys-libs
parentdev-python/moto: Copy ~x86 to 5.0.14 (diff)
downloadgentoo-4c0df1554143725d5059079b9938f0cdab1350d1.tar.gz
gentoo-4c0df1554143725d5059079b9938f0cdab1350d1.tar.bz2
gentoo-4c0df1554143725d5059079b9938f0cdab1350d1.zip
sys-libs/libcxx: Update for temporary install test-suite install
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libcxx/libcxx-20.0.0.9999.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/sys-libs/libcxx/libcxx-20.0.0.9999.ebuild b/sys-libs/libcxx/libcxx-20.0.0.9999.ebuild
index a0d07e1507f4..43c213cc6426 100644
--- a/sys-libs/libcxx/libcxx-20.0.0.9999.ebuild
+++ b/sys-libs/libcxx/libcxx-20.0.0.9999.ebuild
@@ -144,6 +144,11 @@ multilib_src_compile() {
multilib_src_test() {
local -x LIT_PRESERVES_TMP=1
+ cmake_build install-cxx-test-suite-prefix
+ cp "${BUILD_DIR}"/{lib,libcxx/test-suite-install/$(get_libdir)}/libc++_shared.so || die
+ if use static-libs; then
+ cp "${BUILD_DIR}"/{lib,libcxx/test-suite-install/$(get_libdir)}/libc++_static.a || die
+ fi
cmake_build check-cxx
}