summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2024-07-19 10:39:32 +0100
committerJames Le Cuirot <chewi@gentoo.org>2024-07-19 10:57:01 +0100
commit34b7dc479b4ba76ae16b5173b87d3648ae8f4566 (patch)
treea2c9cb60e38bc0c2951719fb4f5760836f8ef1a9 /sys-libs
parentsys-libs/libsepol: Fix installation on prefix for 3.7 (diff)
downloadgentoo-34b7dc479b4ba76ae16b5173b87d3648ae8f4566.tar.gz
gentoo-34b7dc479b4ba76ae16b5173b87d3648ae8f4566.tar.bz2
gentoo-34b7dc479b4ba76ae16b5173b87d3648ae8f4566.zip
sys-libs/libsepol: Add static-libs USE flag for 3.7
It would be better to avoid building the static libs in the first place, but this is more involved. Closes: https://bugs.gentoo.org/726394 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libsepol/libsepol-3.7.ebuild2
-rw-r--r--sys-libs/libsepol/libsepol-9999.ebuild2
2 files changed, 4 insertions, 0 deletions
diff --git a/sys-libs/libsepol/libsepol-3.7.ebuild b/sys-libs/libsepol/libsepol-3.7.ebuild
index 3266c276a3fa..cf71e47eb015 100644
--- a/sys-libs/libsepol/libsepol-3.7.ebuild
+++ b/sys-libs/libsepol/libsepol-3.7.ebuild
@@ -23,6 +23,7 @@ fi
LICENSE="GPL-2"
SLOT="0/2"
+IUSE="static-libs"
# tests are not meant to be run outside of the full SELinux userland repo
RESTRICT="test"
@@ -50,4 +51,5 @@ multilib_src_compile() {
multilib_src_install() {
my_make DESTDIR="${D}" install
+ use static-libs || rm "${ED}"/usr/$(get_libdir)/*.a || die
}
diff --git a/sys-libs/libsepol/libsepol-9999.ebuild b/sys-libs/libsepol/libsepol-9999.ebuild
index 3266c276a3fa..cf71e47eb015 100644
--- a/sys-libs/libsepol/libsepol-9999.ebuild
+++ b/sys-libs/libsepol/libsepol-9999.ebuild
@@ -23,6 +23,7 @@ fi
LICENSE="GPL-2"
SLOT="0/2"
+IUSE="static-libs"
# tests are not meant to be run outside of the full SELinux userland repo
RESTRICT="test"
@@ -50,4 +51,5 @@ multilib_src_compile() {
multilib_src_install() {
my_make DESTDIR="${D}" install
+ use static-libs || rm "${ED}"/usr/$(get_libdir)/*.a || die
}