summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2022-10-31 10:33:46 -0700
committerPatrick McLean <chutzpah@gentoo.org>2022-10-31 10:50:28 -0700
commitcc8879ac81709b076b714a4663ddddc1761495bf (patch)
tree6729521646c8ceaf10a41162e303a9fb337f25b6 /sys-libs/libnvme
parentsci-libs/pdal: fix test interferences (diff)
downloadgentoo-cc8879ac81709b076b714a4663ddddc1761495bf.tar.gz
gentoo-cc8879ac81709b076b714a4663ddddc1761495bf.tar.bz2
gentoo-cc8879ac81709b076b714a4663ddddc1761495bf.zip
sys-libs/libnvme: add 1.2
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'sys-libs/libnvme')
-rw-r--r--sys-libs/libnvme/Manifest1
-rw-r--r--sys-libs/libnvme/libnvme-1.2.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/sys-libs/libnvme/Manifest b/sys-libs/libnvme/Manifest
index f5044c8d3907..13a38b86438d 100644
--- a/sys-libs/libnvme/Manifest
+++ b/sys-libs/libnvme/Manifest
@@ -1,2 +1,3 @@
DIST libnvme-1.0.tar.gz 323956 BLAKE2B 66d8c6b32be1f07306ddfad336e11c2c34e64223344af6d8995ca691658f819c667a96ffb567d1315c19cb5e34dfc217bf6e00bcee1d86d616395d0d58718683 SHA512 119c5f0f6eef47c8922d7c40ff8b6374e211364d8d2df64f1fcc72f2f83216fd81d55e7667d126ab6304128bb58f8e491f845b5a247f64b639a1654a57580f7c
DIST libnvme-1.1.tar.gz 449185 BLAKE2B 8914ded0dd3bcd39bef382ebe4f5d136ae20a3ebd08004ca190e6ce6655b572aef503df2a8d4f020a4a3d44b4c3b49b46c55707e8fe24899d05fa85c2080f641 SHA512 4cff793506566ff493db0026aac6271003c21c691a459fe5e3b45fe42655b78b1e19aea4b848e4d9535f43782945738500b2f42c3615379110e9938c8b105869
+DIST libnvme-1.2.tar.gz 484397 BLAKE2B ae6b1c3aa8f45594219470059cfc8982674433772f89faab1659811d860036f8af89bbcb383db37e96b763188935d2c1ecaa5176b8140bba50f8ea226e989a06 SHA512 f50517838cd1df3cdd123afdb67870633e9e484bf84dba70b784d7e86ecb355b96ba9d6a1cffb96b35444da7870dfe21c54b69701b5fe5b515319280db4a84e4
diff --git a/sys-libs/libnvme/libnvme-1.2.ebuild b/sys-libs/libnvme/libnvme-1.2.ebuild
new file mode 100644
index 000000000000..ab243c0836c3
--- /dev/null
+++ b/sys-libs/libnvme/libnvme-1.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+inherit python-utils-r1 python-r1 meson
+
+DESCRIPTION="C Library for NVM Express on Linux"
+HOMEPAGE="https://github.com/linux-nvme/libnvme"
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="+json python ssl +uuid"
+
+SRC_URI="https://github.com/linux-nvme/libnvme/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ json? ( dev-libs/json-c:= )
+ python? ( ${PYTHON_DEPS} )
+ ssl? ( >=dev-libs/openssl-1.1:= )
+ uuid? ( sys-apps/util-linux:= )
+"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dpython=false
+ )
+ meson_src_configure
+}
+
+python_compile() {
+ local emesonargs=(
+ -Dpython=true
+ )
+ meson_src_configure --reconfigure
+ meson_src_compile
+}
+
+src_compile() {
+ meson_src_compile
+ python_copy_sources
+
+ use python && python_foreach_impl python_compile
+}
+
+python_install() {
+ meson_src_install
+ python_optimize
+}
+
+src_install() {
+ use python && python_foreach_impl python_install
+
+ meson_src_install
+}