summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-11-23 16:40:31 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-11-23 16:40:44 +0100
commit0ab2cd8af265a1875af528e465295186dc475c8c (patch)
tree9b0d88c26a86d86b92d40e05082b9c160f6b0602 /sys-libs/libhx/libhx-3.24.ebuild
parentsys-kernel/gentoo-sources: Linux patch 4.19.4 (diff)
downloadgentoo-0ab2cd8af265a1875af528e465295186dc475c8c.tar.gz
gentoo-0ab2cd8af265a1875af528e465295186dc475c8c.tar.bz2
gentoo-0ab2cd8af265a1875af528e465295186dc475c8c.zip
sys-libs/libhx: Bump to version 3.24
non-maintainer commit due to maintainer timeout. Closes: https://bugs.gentoo.org/669672 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-libs/libhx/libhx-3.24.ebuild')
-rw-r--r--sys-libs/libhx/libhx-3.24.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-libs/libhx/libhx-3.24.ebuild b/sys-libs/libhx/libhx-3.24.ebuild
new file mode 100644
index 000000000000..6024143f546a
--- /dev/null
+++ b/sys-libs/libhx/libhx-3.24.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Platform independent library providing basic system functions"
+HOMEPAGE="http://libhx.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/libHX-${PV}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+DEPEND="app-arch/xz-utils"
+RDEPEND=""
+
+S="${WORKDIR}/libHX-${PV}"
+
+PATCHES=( "${FILESDIR}/${PN}-3.22-no-lyx.patch" )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ if use doc; then
+ dodoc doc/*.txt
+ else
+ dodoc doc/changelog.txt
+ rm "${D}/usr/share/doc/${PF}/"*.pdf || die
+ fi
+
+ find "${ED}" -name "*.la" -delete || die
+}