summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-libs/libacpi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-libs/libacpi')
-rw-r--r--sys-libs/libacpi/Manifest1
-rw-r--r--sys-libs/libacpi/files/libacpi-0.2.patch81
-rw-r--r--sys-libs/libacpi/libacpi-0.2.ebuild29
-rw-r--r--sys-libs/libacpi/metadata.xml8
4 files changed, 119 insertions, 0 deletions
diff --git a/sys-libs/libacpi/Manifest b/sys-libs/libacpi/Manifest
new file mode 100644
index 000000000000..76620b0e2328
--- /dev/null
+++ b/sys-libs/libacpi/Manifest
@@ -0,0 +1 @@
+DIST libacpi-0.2.tar.gz 104881 SHA256 13086e31d428b9c125954d48ac497b754bbbce2ef34ea29ecd903e82e25bad29
diff --git a/sys-libs/libacpi/files/libacpi-0.2.patch b/sys-libs/libacpi/files/libacpi-0.2.patch
new file mode 100644
index 000000000000..f3f2b5e98cca
--- /dev/null
+++ b/sys-libs/libacpi/files/libacpi-0.2.patch
@@ -0,0 +1,81 @@
+--- config.mk
++++ config.mk
+@@ -3,15 +3,17 @@
+ SONAME = libacpi.so.${SOVERSION}
+
+ # customize below to fit your system
+-PREFIX = /usr/local
++PREFIX = /usr
+ MANPREFIX = ${PREFIX}/share/man
++DOCDIR = ${PREFIX}/share/doc/libacpi-${VERSION}
++LIBDIR = ${PREFIX}/lib
+
+ # flags
+ SOFLAGS = -shared -Wl,-soname,${SONAME}
+-CFLAGS += -fPIC -g --pedantic -Wall -Wextra
++CFLAGS += -fPIC -pedantic -Wall -Wextra
+
+ # Compiler and linker
+-CC = cc
++CC ?= cc
+ LD = ${CC}
+-AR = ar cr
+-RANLIB = ranlib
++AR ?= ar
++RANLIB ?= ranlib
+--- Makefile
++++ Makefile
+@@ -25,30 +25,29 @@
+
+ libacpi.a: ${OBJ}
+ @echo AR $@
+- @${AR} $@ ${OBJ}
++ @${AR} cr $@ ${OBJ}
+ @${RANLIB} $@
+
+ libacpi.so: ${OBJ}
+ @echo LD $@
+- @${LD} ${SOFLAGS} -o $@.${SOVERSION} ${OBJ}
++ @${LD} ${LDFLAGS} ${SOFLAGS} -o $@.${SOVERSION} ${OBJ}
+
+ test-libacpi: ${OBJ_test}
+ @echo LD $@
+- @${LD} -o $@ ${OBJ_test} ${LDFLAGS}
+- @strip $@
++ @${LD} ${LDFLAGS} -o $@ ${OBJ_test}
+
+ install: all
+ @echo installing header to ${DESTDIR}${PREFIX}/include
+ @mkdir -p ${DESTDIR}${PREFIX}/include
+ @cp -f libacpi.h ${DESTDIR}${PREFIX}/include
+ @chmod 644 ${DESTDIR}${PREFIX}/include/libacpi.h
+- @echo installing library to ${DESTDIR}${PREFIX}/lib
+- @mkdir -p ${DESTDIR}${PREFIX}/lib
+- @cp -f libacpi.a ${DESTDIR}${PREFIX}/lib
+- @chmod 644 ${DESTDIR}${PREFIX}/lib/libacpi.a
+- @cp -f ${SONAME} ${DESTDIR}${PREFIX}/lib/
+- @chmod 644 ${DESTDIR}${PREFIX}/lib/${SONAME}
+- @ln -s ${SONAME} ${DESTDIR}${PREFIX}/lib/libacpi.so
++ @echo installing library to ${DESTDIR}${LIBDIR}
++ @mkdir -p ${DESTDIR}${LIBDIR}
++ @cp -f libacpi.a ${DESTDIR}${LIBDIR}
++ @chmod 644 ${DESTDIR}${LIBDIR}/libacpi.a
++ @cp -f ${SONAME} ${DESTDIR}${LIBDIR}/
++ @chmod 644 ${DESTDIR}${LIBDIR}/${SONAME}
++ @ln -s ${SONAME} ${DESTDIR}${LIBDIR}/libacpi.so
+ @echo installing test-libacpi to ${DESTDIR}${PREFIX}/bin
+ @mkdir -p ${DESTDIR}${PREFIX}/bin
+ @cp -f test-libacpi ${DESTDIR}${PREFIX}/bin
+@@ -56,9 +55,9 @@
+ @echo installing manual page to ${DESTDIR}${MANPREFIX}/man3
+ @mkdir -p ${DESTDIR}${MANPREFIX}/man3
+ @cp libacpi.3 ${DESTDIR}${MANPREFIX}/man3
+- @echo installing documentation and misc files to ${DESTDIR}${PREFIX}/share/doc/libacpi
+- @mkdir -p ${DESTDIR}${PREFIX}/share/doc/libacpi
+- @cp -r AUTHORS CHANGES README LICENSE doc ${DESTDIR}${PREFIX}/share/doc/libacpi
++ @echo installing documentation and misc files to ${DESTDIR}${DOCDIR}
++ @mkdir -p ${DESTDIR}${DOCDIR}
++ @cp -r AUTHORS CHANGES README doc/* ${DESTDIR}${DOCDIR}
+ @echo finished installation
+
+ uninstall:
diff --git a/sys-libs/libacpi/libacpi-0.2.ebuild b/sys-libs/libacpi/libacpi-0.2.ebuild
new file mode 100644
index 000000000000..1a46dfff9732
--- /dev/null
+++ b/sys-libs/libacpi/libacpi-0.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="A general purpose library for ACPI"
+HOMEPAGE="http://www.ngolde.de/libacpi.html"
+SRC_URI="http://www.ngolde.de/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}.patch
+}
+
+src_compile() {
+ tc-export AR CC RANLIB
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)" install || die
+ prepalldocs
+}
diff --git a/sys-libs/libacpi/metadata.xml b/sys-libs/libacpi/metadata.xml
new file mode 100644
index 000000000000..c2d865517c00
--- /dev/null
+++ b/sys-libs/libacpi/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>ssuominen@gentoo.org</email>
+ <name>Samuli Suominen</name>
+ </maintainer>
+</pkgmetadata>