summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZen <z@pyl.onl>2024-08-09 16:07:10 -0500
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-08-10 10:45:35 +0200
commite488998cf32b87ff80081eee505ccf1d7d47c7ad (patch)
treec8bd2b1ebf71126f71b82b3043c4b4d915922591 /sys-kernel
parentdev-python/zenlib: add 2.2.2 (diff)
downloadgentoo-e488998cf32b87ff80081eee505ccf1d7d47c7ad.tar.gz
gentoo-e488998cf32b87ff80081eee505ccf1d7d47c7ad.tar.bz2
gentoo-e488998cf32b87ff80081eee505ccf1d7d47c7ad.zip
sys-kernel/ugrd: add 1.17.0
Signed-off-by: Zen <z@pyl.onl> Closes: https://github.com/gentoo/gentoo/pull/38035 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/ugrd/Manifest1
-rw-r--r--sys-kernel/ugrd/ugrd-1.17.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/sys-kernel/ugrd/Manifest b/sys-kernel/ugrd/Manifest
index 0027fa4f19c1..37cfe1987723 100644
--- a/sys-kernel/ugrd/Manifest
+++ b/sys-kernel/ugrd/Manifest
@@ -1,2 +1,3 @@
DIST ugrd-1.13.0.tar.gz 63781 BLAKE2B 3f2d3095c6303b16947121071dabdbef81baaea5a7e208d53250e57edf136618497710ce3cca2906b87fbdc529b8a9ef119659365bba8c795594774cf8d096f6 SHA512 a745685668e981accfd32d1c47c6cf506ae63304ef5b3fdad200731db75b76fe56a4339876465bb1857c2fed35c273f95bbce390224fa0d01aebd67adbc31aa6
DIST ugrd-1.16.0.tar.gz 66050 BLAKE2B 50417d15a50f3e6da2609d61f4a88f4bafe76d02f82ce4a8f8b152e311a68543956c30487a7caee769c8da2a266d9266377a798b6577f4b3d54164acb55f20fc SHA512 ac67a5164c2d239a5994bfde972bf82fe9f63bfc339ad263256e9889826ff71df224a8d003b0db2e2900d862dbd2a07c11c1b99fe12f94e52a8c5cd65ef302e5
+DIST ugrd-1.17.0.tar.gz 69517 BLAKE2B 2acadac8ab3830791146522ccfff6f8c5e98eff4cea355dafd5f5498bedf5d0f200ec2bc2ee4a20c62e3920590c70b2c788c776c148e7291cd3391eb2e0018df SHA512 5caeebadb579536a60cecd6c9fd9036c178ab5c5700418b95841e7102ac0c3c5fa14ceebc9994a86f65bd0623ca819ed7cb7a986f412e0358c9597c0e579f90c
diff --git a/sys-kernel/ugrd/ugrd-1.17.0.ebuild b/sys-kernel/ugrd/ugrd-1.17.0.ebuild
new file mode 100644
index 000000000000..204c70be070a
--- /dev/null
+++ b/sys-kernel/ugrd/ugrd-1.17.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+inherit distutils-r1 optfeature shell-completion
+
+DESCRIPTION="Python based initramfs generator with TOML defintions"
+HOMEPAGE="https://github.com/desultory/ugrd"
+SRC_URI="https://github.com/desultory/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ app-misc/pax-utils
+ >=dev-python/zenlib-2.2.2[${PYTHON_USEDEP}]
+ >=dev-python/pycpio-1.2.1[${PYTHON_USEDEP}]
+ sys-apps/pciutils
+"
+
+python_install_all() {
+ # Call the distutils-r1_python_install_all function
+ distutils-r1_python_install_all
+ # Install the example config into /etc/ugrd/config.toml
+ # Do not overwrite an existing config
+ insinto /etc/ugrd
+ newins examples/example.toml config.toml
+
+ # Install the kernel preinst.d hook
+ exeinto /usr/lib/kernel/preinst.d
+ doexe hooks/installkernel/52-ugrd.install
+ exeinto /usr/lib/kernel/install.d
+ doexe hooks/kernel-install/52-ugrd.install
+
+ dobashcomp completion/ugrd # Install bash autocomplete script
+ dozshcomp completion/_ugrd # Install zsh autocomplete script
+}
+
+pkg_postinst() {
+ optfeature "ugrd.crypto.cryptsetup support" sys-fs/cryptsetup
+ optfeature "ugrd.fs.btrfs support" sys-fs/btrfs-progs
+ optfeature "ugrd.crypto.gpg support" app-crypt/gnupg
+ optfeature "ugrd.fs.lvm support" sys-fs/lvm2[lvm]
+}