summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2021-05-15 08:42:18 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-05-15 09:00:39 +0300
commit6d1d409ca9a08e1e409751f0782d2b91ddf9e07c (patch)
tree9e2d81528cb32f0c2aaed30466182c6187e1462e /sys-kernel/pf-sources
parentdev-ruby/nokogiri: cleanup (diff)
downloadgentoo-6d1d409ca9a08e1e409751f0782d2b91ddf9e07c.tar.gz
gentoo-6d1d409ca9a08e1e409751f0782d2b91ddf9e07c.tar.bz2
gentoo-6d1d409ca9a08e1e409751f0782d2b91ddf9e07c.zip
sys-kernel/pf-sources: bump to 5.12-pf2
Signed-off-by: Joonas Niilola <juippis@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/20812
Diffstat (limited to 'sys-kernel/pf-sources')
-rw-r--r--sys-kernel/pf-sources/Manifest1
-rw-r--r--sys-kernel/pf-sources/pf-sources-5.12_p2.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/sys-kernel/pf-sources/Manifest b/sys-kernel/pf-sources/Manifest
index 469c1d8c907c..833e87cf54c9 100644
--- a/sys-kernel/pf-sources/Manifest
+++ b/sys-kernel/pf-sources/Manifest
@@ -24,4 +24,5 @@ DIST pf-sources-5.11_p6.patch 5055069 BLAKE2B 75ea4ce13e12762c282c51f07a4bf4553d
DIST pf-sources-5.11_p7.patch 5538351 BLAKE2B 112f27ae4c640b5398dea06eb85b3f88518e9dfc94bcf104114cdd7d8a33a85c2decf32a696d8ce648c344cdf018af0b588b11785cb33394394a32f38b1d52db SHA512 f957283309a6d2116c0f130e59e944baf3b91d72991e5f74317e8badc6962153deccf4ba376fc33ff50ddae2d6f1b1f2d3419c68a036ec8fc68e94cfcd11c789
DIST pf-sources-5.11_p8.patch 5688583 BLAKE2B 5d845677efd1d6ac95282d24223c7aa26d33ea74670b37184fda20dded42b5de1c4b4fd06f29afb12c8fd3372feb208b7d655c1dba3b60cfd1f4dc5cecfe5116 SHA512 62105aa308543ae5bb2e79be77dd77f3d4d3430669423c6e9e528acb114edf3b3a3cdcc2371ea566a6a51dbc16ebfba64187dabf485a96dea7c0127162173675
DIST pf-sources-5.12_p1.patch 2785321 BLAKE2B 6010dcc736c6e068cb5aed9df790df6795f8b85f4169b9b6b66eb020f0e1821cd29630f421842c172f52fb41e4ac94f1671d506ec3f72f0bc883adbadd258302 SHA512 a861f3f96205de0c86a506bfd470116eeaabc8ec574e1940572abdfe166e16539f2fe874af5a0ea234741e5385e88491a49ba390a5493efc2fcc0c0283b43aa6
+DIST pf-sources-5.12_p2.patch 4252808 BLAKE2B 2c23009ba31caa7f5e6268d854af2bb2f9db2831a67cb34ef535fe1914d913f057f514aa8ce7c1a8a63374498c56d9bcce0662ed4ec3a888e2e7518b339196c1 SHA512 e2da600deeea7e16667bd0c9e0be9349f47441a4d9c2f06f66fb4f2a78c1b2c596a502cc35c6d9aea3ffcdb26461299f3446b5bb5a9b88b059806eb4db80d2b2
DIST pf-sources-5.9_p7.patch 3027972 BLAKE2B 9247ea63b30f9d42d79303b73a900d468a71e703333932f7f15ae697cdba52c46358297023e037226c219fad5df912fb5d21e6f4b7190556ca799fa84924480e SHA512 c69e14f59bf98944b3329c65b7e2c271d74a756bc8c890130bf3cc68b4b96d31f1c33c4edb128580fcaefeb6e42dd04b1eb3d7f071b2d58bc764d26322bda8cd
diff --git a/sys-kernel/pf-sources/pf-sources-5.12_p2.ebuild b/sys-kernel/pf-sources/pf-sources-5.12_p2.ebuild
new file mode 100644
index 000000000000..7e09f4442745
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-5.12_p2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# Define what default functions to run
+ETYPE="sources"
+
+# No 'experimental' USE flag provided, but we still want to use genpatches
+K_EXP_GENPATCHES_NOUSE="1"
+
+# Just get basic genpatches, -pf patch set already includes vanilla-linux updates
+K_GENPATCHES_VER="1"
+
+# -pf already sets EXTRAVERSION to kernel Makefile
+K_NOSETEXTRAVERSION="1"
+
+# Not supported by the Gentoo security team
+K_SECURITY_UNSUPPORTED="1"
+
+# We want the very basic patches from gentoo-sources, experimental patch is
+# already included in pf-sources
+K_WANT_GENPATCHES="base extras"
+
+SHPV="${PV/_p*/}"
+
+inherit kernel-2 optfeature
+detect_version
+
+DESCRIPTION="Linux kernel fork that includes the pf-kernel patchset and Gentoo's genpatches"
+HOMEPAGE="https://gitlab.com/post-factum/pf-kernel/-/wikis/README
+ https://dev.gentoo.org/~mpagano/genpatches/"
+SRC_URI="${KERNEL_URI}
+ https://github.com/pfactum/pf-kernel/compare/v${SHPV}...v${SHPV}-pf${PV/*_p/}.diff -> ${P}.patch
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${SHPV}-${K_GENPATCHES_VER}.base.tar.xz
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${SHPV}-${K_GENPATCHES_VER}.extras.tar.xz
+ https://raw.githubusercontent.com/GKernelCI/linux-patches/${SHPV}/5020_BMQ-and-PDS-io-scheduler-v${SHPV}-r0.patch
+ https://raw.githubusercontent.com/GKernelCI/linux-patches/${SHPV}/5021_BMQ-and-PDS-gentoo-defaults-v${SHPV}-r0.patch"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+S="${WORKDIR}/linux-${PVR}-pf"
+
+PATCHES=( "${DISTDIR}/${P}.patch"
+ "${DISTDIR}/5020_BMQ-and-PDS-io-scheduler-v${SHPV}-r0.patch"
+ "${DISTDIR}/5021_BMQ-and-PDS-gentoo-defaults-v${SHPV}-r0.patch"
+)
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems,
+ see: ${HOMEPAGE}."
+
+pkg_setup() {
+ ewarn ""
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn ""
+
+ kernel-2_pkg_setup
+}
+
+src_prepare() {
+ # kernel-2_src_prepare doesn't apply PATCHES().
+ default
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ optfeature "userspace KSM helper" sys-process/uksmd
+}