summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2024-08-30 17:20:47 +0200
committerJakov Smolić <jsmolic@gentoo.org>2024-08-30 17:20:47 +0200
commitb0f75d3ed8da976ecc5154a17f92f17cef2179db (patch)
tree38a595d3e3ee636bb63c2712e7095d9b50137545 /sys-fs
parentsys-fs/clamfs: drop 1.2.0 (diff)
downloadgentoo-b0f75d3ed8da976ecc5154a17f92f17cef2179db.tar.gz
gentoo-b0f75d3ed8da976ecc5154a17f92f17cef2179db.tar.bz2
gentoo-b0f75d3ed8da976ecc5154a17f92f17cef2179db.zip
sys-fs/bashmount: update EAPI 7 -> 8
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/bashmount/bashmount-4.3.2-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-fs/bashmount/bashmount-4.3.2-r2.ebuild b/sys-fs/bashmount/bashmount-4.3.2-r2.ebuild
new file mode 100644
index 000000000000..834ce078e693
--- /dev/null
+++ b/sys-fs/bashmount/bashmount-4.3.2-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Bash script that uses udisks to mount removable devices without GUI"
+HOMEPAGE="https://github.com/jamielinux/bashmount"
+SRC_URI="https://github.com/jamielinux/bashmount/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+# sys-apps/util-linux -> lsblk
+RDEPEND="
+ app-shells/bash:*
+ sys-apps/dbus
+ sys-apps/util-linux
+ sys-fs/udisks:2
+"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ dobin ${PN}
+ insinto /etc
+ doins ${PN}.conf
+ doman ${PN}.1
+ dodoc NEWS
+}