summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorBrahmajit Das <brahmajit.xyz@gmail.com>2024-06-26 23:37:10 +0530
committerJoonas Niilola <juippis@gentoo.org>2024-06-27 08:17:37 +0300
commit6714ea417f5f5b282e6f666a3d51095b2cabd0f1 (patch)
treebd6f1dde0be0cedae21079a87be28b4fbd6a1daf /sys-fs
parentdev-ruby/async-pool: add 0.7.0 (diff)
downloadgentoo-6714ea417f5f5b282e6f666a3d51095b2cabd0f1.tar.gz
gentoo-6714ea417f5f5b282e6f666a3d51095b2cabd0f1.tar.bz2
gentoo-6714ea417f5f5b282e6f666a3d51095b2cabd0f1.zip
sys-fs/lxcfs: add 6.0.1
Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/37314 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/lxcfs/Manifest2
-rw-r--r--sys-fs/lxcfs/lxcfs-6.0.1.ebuild80
2 files changed, 82 insertions, 0 deletions
diff --git a/sys-fs/lxcfs/Manifest b/sys-fs/lxcfs/Manifest
index ddfde18b76ed..94edd76b41ce 100644
--- a/sys-fs/lxcfs/Manifest
+++ b/sys-fs/lxcfs/Manifest
@@ -2,3 +2,5 @@ DIST lxcfs-5.0.4.tar.gz 104249 BLAKE2B 83a7b861136c34da8a24dd525fd0767193f2bbd92
DIST lxcfs-5.0.4.tar.gz.asc 833 BLAKE2B aff883d24b374b296ea3678670e5e82c723fd0e35cfd7fed555aabbd811a104becc0b741331b4aa4a5129c9fff4dc88c6a86e7d64a89fe86aea81718f5d432dd SHA512 56b639597dbaf3008fe030147ea37192bd465c467a79e11ce139bcaa6bca1625b4bb9c4eda6ea1877446769f0fad9b4c5a3513d4f4415b841db96d5da8325ddc
DIST lxcfs-6.0.0.tar.gz 103369 BLAKE2B 9261ab7d932d315117361a548372930c37129d3c1b3d5aa00bbce6bac923a94e69b0fa223632b1ef22938b047e6ebec7416cf187e76c72680e4d86db173d199a SHA512 fab5569da66a742a51c9f249c3f0256d1ea17dc0a1e7c2d5563d993cd0d236ae664a53809e65fbec2467f5d255dfd867327a28d9465ffe180d240ca131331c59
DIST lxcfs-6.0.0.tar.gz.asc 833 BLAKE2B cfc6a8e574aeb1c9e3fec322df5254c431878f0109ea43ee1069e8213467ed16fedbe137befa47a2557d8c055591a9f00c99f221d482f715d5cdc678d79c5fa5 SHA512 019178b37045c3c2c4d8be7c417abb4ed8b7ce011bce805b220f6213d7940f164c45632a5ce02ea29451c8148f782d6b7ece7699da7f3ef7306bd437d40fe537
+DIST lxcfs-6.0.1.tar.gz 105761 BLAKE2B 87255711eccc9833cd321c5d606920edcbf87a2a380cb2993efeb08040e22ab6bda408429fe02b731e60b293da946c1c44f6aad6f82db871e49b2bfeb2c34172 SHA512 3e5ab8af0fd81b1b0ac83ce781b20a55c1c1277a01edbca07106534043a0070291331775b7fa4e1c005b54d24d690ad9abe9b208de749a70dcff853741d02fd4
+DIST lxcfs-6.0.1.tar.gz.asc 833 BLAKE2B b9a6655650f5720fce4bb2e9dcace2b1c3ec7f0b14b2b23014142a1fce2cd55b3ae7361e7ead9385893068ca9f18cef4151bfb223d005a4c810c5efc40b8fb7a SHA512 d795a18170027d33f94c2bf88d5ad4c6162e066f9a51d7eab79699cc3b04c058e8f1bf00a8242a233727dfae8888050b17cd96a3abb05d02e0da05298b6eb4c4
diff --git a/sys-fs/lxcfs/lxcfs-6.0.1.ebuild b/sys-fs/lxcfs/lxcfs-6.0.1.ebuild
new file mode 100644
index 000000000000..c0e7a84ec0f5
--- /dev/null
+++ b/sys-fs/lxcfs/lxcfs-6.0.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit cmake meson python-any-r1 systemd verify-sig
+
+DESCRIPTION="FUSE filesystem for LXC"
+HOMEPAGE="https://linuxcontainers.org/lxcfs/introduction/ https://github.com/lxc/lxcfs/"
+SRC_URI="https://linuxcontainers.org/downloads/lxcfs/${P}.tar.gz
+ verify-sig? ( https://linuxcontainers.org/downloads/lxcfs/${P}.tar.gz.asc )"
+
+LICENSE="Apache-2.0 LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="doc test"
+
+DEPEND="sys-fs/fuse:3"
+RDEPEND="${DEPEND}"
+BDEPEND="${PYTHON_DEPS}
+ virtual/pkgconfig
+ $(python_gen_any_dep '
+ dev-python/jinja[${PYTHON_USEDEP}]
+ ')
+ doc? ( sys-apps/help2man )
+ verify-sig? ( sec-keys/openpgp-keys-linuxcontainers )"
+
+# Needs some black magic to work inside container/chroot.
+RESTRICT="test"
+
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/linuxcontainers.asc
+
+python_check_deps() {
+ python_has_version -b "dev-python/jinja[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # Fix python shebangs for python-exec[-native-symlinks], #851480
+ local shebangs=($(grep -rl "#!/usr/bin/env python3" || die))
+ python_fix_shebang -q ${shebangs[*]}
+}
+
+src_configure() {
+ local emesonargs=(
+ --localstatedir "${EPREFIX}/var"
+
+ $(meson_use doc docs)
+ $(meson_use test tests)
+
+ -Dfuse-version=3
+ -Dinit-script=""
+ -Dwith-init-script=""
+ )
+
+ meson_src_configure
+}
+
+src_test() {
+ cd "${BUILD_DIR}"/tests || die "failed to change into tests/ directory."
+ ./main.sh || die
+}
+
+src_install() {
+ meson_src_install
+
+ newconfd "${FILESDIR}"/lxcfs-5.0.2.confd lxcfs
+ newinitd "${FILESDIR}"/lxcfs-5.0.2.initd lxcfs
+
+ # Provide our own service file (copy of upstream) due to paths being different from upstream,
+ # #728470
+ systemd_newunit "${FILESDIR}"/lxcfs-5.0.2.service lxcfs.service
+}