summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-06 08:05:35 +0000
committerSam James <sam@gentoo.org>2023-01-06 08:05:35 +0000
commit368bea0e3e302644295a16616c47ab32b63615dc (patch)
tree98d7fcaf20c1b0684f610efcc2ee4da72a28d99b /sys-fs
parentnet-analyzer/macchanger: add USE=split-usr for netifrc (diff)
downloadgentoo-368bea0e3e302644295a16616c47ab32b63615dc.tar.gz
gentoo-368bea0e3e302644295a16616c47ab32b63615dc.tar.bz2
gentoo-368bea0e3e302644295a16616c47ab32b63615dc.zip
sys-fs/xfsprogs: add 6.1.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/xfsprogs/Manifest1
-rw-r--r--sys-fs/xfsprogs/xfsprogs-6.1.0.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/sys-fs/xfsprogs/Manifest b/sys-fs/xfsprogs/Manifest
index d1c93117287f..6f3a8acc99e8 100644
--- a/sys-fs/xfsprogs/Manifest
+++ b/sys-fs/xfsprogs/Manifest
@@ -1,2 +1,3 @@
DIST xfsprogs-5.18.0.tar.xz 1310008 BLAKE2B a2a2835d53ee6ac55279636f3f3cdcecab8757911ce5c1ea5f350a4da9ff4c1ca64b2aba1c0e5424c0c0a01fd0504396d5fecca12e4689c372ed5bb76b9ac24e SHA512 47d035a33367edae7357e34c70bdb0fe9219231153fb4c4f418ed1462d137dd77338c12a199eb71cd70e88903e5fc11e1e4fb595c622183786e87346e2f65739
DIST xfsprogs-6.0.0.tar.xz 1320744 BLAKE2B ae1d175e3dc5f0f6819397f8166a419847da07616d472f81928e3086b9fac420c09e9406d752a34a957d6d9c82a45defb17d6773e87e3b5f4ff509952ef3e76e SHA512 a3ddccdea1129038420d933f1e9ae8f9e75b3ad59fd0fe4c61b7a4dc6145f47b4262f68aefc3216d37cc33ee5643cd6f260ec83cd39d6b61a1cd046c03674ad8
+DIST xfsprogs-6.1.0.tar.xz 1322908 BLAKE2B 0be85ec90079bb4cb5888785f872365382dc2bdeb9f64780dfd3dd2c8ec5fdea7eda76f5fe683de7f768d5d4b822e85a59e80ed713f196647f5c4431601fab7b SHA512 6b6896ea2312836642fc3536aa47c1b96074c495dfa5876ebf06370f8b64d36df6149798153f86bb6ba3fde54354694f74ee72446dd4c6ab509013d82d25e8b0
diff --git a/sys-fs/xfsprogs/xfsprogs-6.1.0.ebuild b/sys-fs/xfsprogs/xfsprogs-6.1.0.ebuild
new file mode 100644
index 000000000000..22663401ef36
--- /dev/null
+++ b/sys-fs/xfsprogs/xfsprogs-6.1.0.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic systemd usr-ldscript
+
+DESCRIPTION="XFS filesystem utilities"
+HOMEPAGE="https://xfs.wiki.kernel.org/"
+SRC_URI="https://www.kernel.org/pub/linux/utils/fs/xfs/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="icu libedit nls selinux"
+
+RDEPEND="dev-libs/inih
+ dev-libs/userspace-rcu:=
+ >=sys-apps/util-linux-2.17.2
+ icu? ( dev-libs/icu:= )
+ libedit? ( dev-libs/libedit )"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )"
+RDEPEND+=" selinux? ( sec-policy/selinux-xfs )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.3.0-libdir.patch
+ "${FILESDIR}"/${PN}-5.18.0-docdir.patch
+ "${FILESDIR}"/${PN}-5.18.0-include.patch
+)
+
+src_prepare() {
+ default
+
+ # Fix doc dir
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
+ include/builddefs.in || die
+
+ # Don't install compressed docs
+ sed 's@\(CHANGES\)\.gz[[:space:]]@\1 @' -i doc/Makefile || die
+}
+
+src_configure() {
+ # include/builddefs.in will add FCFLAGS to CFLAGS which will
+ # unnecessarily clutter CFLAGS (and fortran isn't used)
+ unset FCFLAGS
+
+ # If set in user env, this breaks configure
+ unset PLATFORM
+
+ export DEBUG=-DNDEBUG
+
+ # Package is honoring CFLAGS; No need to use OPTIMIZER anymore.
+ # However, we have to provide an empty value to avoid default
+ # flags.
+ export OPTIMIZER=" "
+
+ # Avoid automagic on libdevmapper (bug #709694)
+ export ac_cv_search_dm_task_create=no
+
+ # Build fails with -O3 (bug #712698)
+ replace-flags -O3 -O2
+
+ # Upstream does NOT support --disable-static anymore,
+ # https://www.spinics.net/lists/linux-xfs/msg30185.html
+ # https://www.spinics.net/lists/linux-xfs/msg30272.html
+ local myconf=(
+ --enable-blkid
+ --with-crond-dir="${EPREFIX}/etc/cron.d"
+ --with-systemd-unit-dir="$(systemd_get_systemunitdir)"
+ $(use_enable icu libicu)
+ $(use_enable nls gettext)
+ $(use_enable libedit editline)
+ )
+
+ if is-flagq -flto ; then
+ myconf+=( --enable-lto )
+ else
+ myconf+=( --disable-lto )
+ fi
+
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_install() {
+ emake DIST_ROOT="${ED}" HAVE_ZIPPED_MANPAGES=false install
+ emake DIST_ROOT="${ED}" HAVE_ZIPPED_MANPAGES=false install-dev
+
+ gen_usr_ldscript -a handle
+}