summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-23 03:42:22 +0100
committerSam James <sam@gentoo.org>2022-09-23 03:42:22 +0100
commit113ecc58b17cf02f9d1ef1b9b0ccc0978fd86f92 (patch)
treeec3952cea508bb663a4bce843a5f4a12cdef10d2 /sys-fs
parentsys-process/at: Stabilize 3.2.5 amd64, #872431 (diff)
downloadgentoo-113ecc58b17cf02f9d1ef1b9b0ccc0978fd86f92.tar.gz
gentoo-113ecc58b17cf02f9d1ef1b9b0ccc0978fd86f92.tar.bz2
gentoo-113ecc58b17cf02f9d1ef1b9b0ccc0978fd86f92.zip
sys-fs/quota: add 4.09
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/quota/Manifest1
-rw-r--r--sys-fs/quota/files/quota-4.09-configure-bashism.patch16
-rw-r--r--sys-fs/quota/files/quota-4.09-gettext-version.patch14
-rw-r--r--sys-fs/quota/quota-4.09.ebuild84
4 files changed, 115 insertions, 0 deletions
diff --git a/sys-fs/quota/Manifest b/sys-fs/quota/Manifest
index ebd4c38e4346..c18c1f799be4 100644
--- a/sys-fs/quota/Manifest
+++ b/sys-fs/quota/Manifest
@@ -1 +1,2 @@
DIST quota-4.06.tar.gz 520448 BLAKE2B 2cbadeade228d0154f3a8d455cc1aa6e85c9ad7854007e3188c9035abe4d5fdbdf97985fd2fa6308f486ffbe60461e0fe1139f1ec0ca415ce08292d74e0ddde1 SHA512 cece46b8e3a82e8afcf8bfc9f6b310ec91afe034102cebc031bc7d7e04287fdbffb21ab1d3e6e1825175cffa4bad0a4ecbefec0efee028d961b14ac626d5c871
+DIST quota-4.09.tar.gz 523191 BLAKE2B 30b3828a45dcd7d99ff053f362917c138b1f0bcbde5f6fd3dfc1b48cb12615e5673d852f9276f2b370f9c799a2103e220d91ddf6a770aaaf8944cfb5c1131a74 SHA512 003d45f33543d4c87446e6547079cdae293b8dade01c58cf3626623721a1400ee07681395ad656c23a9ea2a62ab27c6ad24ad55600890e6e25334aba27ab1ad5
diff --git a/sys-fs/quota/files/quota-4.09-configure-bashism.patch b/sys-fs/quota/files/quota-4.09-configure-bashism.patch
new file mode 100644
index 000000000000..5866d3873dde
--- /dev/null
+++ b/sys-fs/quota/files/quota-4.09-configure-bashism.patch
@@ -0,0 +1,16 @@
+https://sourceforge.net/p/linuxquota/patches/56/
+
+configure: WARNING: tcpd.h not found
+./configure: 8453: test: X: unexpected operator
+checking that generated files are newer than configure... done
+--- a/configure.ac
++++ b/configure.ac
+@@ -283,7 +283,7 @@ AC_ARG_WITH([pid-dir],
+ [AS_HELP_STRING([--with-pid-dir=DIRECTORY], [Create PID files in this directory instead of /var/run])],
+ [with_pid_dir="$withval"]
+ )
+-AS_IF([test "X$with_pid_dir" == "X" -o "$with_pid_dir" == "yes" -o "$with_pid_dir" == "no"],[
++AS_IF([test "X$with_pid_dir" = "X" -o "$with_pid_dir" = "yes" -o "$with_pid_dir" = "no"],[
+ with_pid_dir="/var/run"
+ ])
+ AC_DEFINE_UNQUOTED([PID_DIR], ["$with_pid_dir"], [Directory for PID files])
diff --git a/sys-fs/quota/files/quota-4.09-gettext-version.patch b/sys-fs/quota/files/quota-4.09-gettext-version.patch
new file mode 100644
index 000000000000..1dc194f8b473
--- /dev/null
+++ b/sys-fs/quota/files/quota-4.09-gettext-version.patch
@@ -0,0 +1,14 @@
+https://sourceforge.net/p/linuxquota/bugs/142/
+
+Avoids e.g. egrep warnings.
+--- a/configure.ac
++++ b/configure.ac
+@@ -43,7 +43,7 @@ AC_CHECK_FUNC([nl_langinfo], [
+ # Gettext support
+ # ===============
+ AM_GNU_GETTEXT([external])
+-AM_GNU_GETTEXT_VERSION([0.12.1])
++AM_GNU_GETTEXT_VERSION([0.21])
+
+ AS_IF([test "$enable_nls" != "no"], [
+ enable_nls="yes"
diff --git a/sys-fs/quota/quota-4.09.ebuild b/sys-fs/quota/quota-4.09.ebuild
new file mode 100644
index 000000000000..2c2297f50915
--- /dev/null
+++ b/sys-fs/quota/quota-4.09.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Linux quota tools"
+HOMEPAGE="https://sourceforge.net/projects/linuxquota/"
+SRC_URI="mirror://sourceforge/linuxquota/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="ldap netlink nls rpc tcpd"
+
+RDEPEND="
+ sys-fs/e2fsprogs
+ ldap? ( >=net-nds/openldap-2.3.35:= )
+ netlink? (
+ sys-apps/dbus
+ dev-libs/libnl:3
+ )
+ rpc? (
+ elibc_glibc? ( sys-libs/glibc[-rpc(-)] )
+ net-libs/libtirpc:=
+ net-libs/rpcsvc-proto
+ )
+ tcpd? ( sys-apps/tcp-wrappers )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )"
+PDEPEND="rpc? ( net-nds/rpcbind )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.09-configure-bashism.patch
+ "${FILESDIR}"/${PN}-4.09-gettext-version.patch
+)
+
+src_prepare() {
+ default
+
+ # Only needed for bashism patch and stale macros patch
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-ext2direct
+ $(use_enable nls)
+ $(use_enable ldap ldapmail)
+ $(use_enable netlink)
+ $(use_enable rpc)
+ $(use_enable rpc rpcsetquota)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc doc/* README.* Changelog
+
+ insinto /etc
+ insopts -m0644
+ doins warnquota.conf quotatab
+
+ newinitd "${FILESDIR}"/quota.rc7 quota
+ newconfd "${FILESDIR}"/quota.confd quota
+
+ if use rpc ; then
+ newinitd "${FILESDIR}"/rpc.rquotad.initd rpc.rquotad
+ fi
+
+ if use ldap ; then
+ insinto /etc/openldap/schema
+ insopts -m0644
+ doins "${FILESDIR}"/ldap-scripts/quota.schema
+
+ exeinto /usr/share/quota/ldap-scripts
+ doexe "${FILESDIR}"/ldap-scripts/*.pl
+ doexe "${FILESDIR}"/ldap-scripts/edquota_editor
+ fi
+}