summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-04-14 09:12:58 +0200
committerMichał Górny <mgorny@gentoo.org>2019-04-14 09:12:58 +0200
commit4d18f25cfa99ad87cab8ddf1896ba76311395206 (patch)
tree850896b556bcdd75110a54f78533b8b0198fc227 /sys-fs/vhba
parentdev-python/pyliblzma: Remove last-rited pkg (diff)
downloadgentoo-4d18f25cfa99ad87cab8ddf1896ba76311395206.tar.gz
gentoo-4d18f25cfa99ad87cab8ddf1896ba76311395206.tar.bz2
gentoo-4d18f25cfa99ad87cab8ddf1896ba76311395206.zip
sys-fs/vhba: Bump to 20190410
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-fs/vhba')
-rw-r--r--sys-fs/vhba/Manifest1
-rw-r--r--sys-fs/vhba/vhba-20190410.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/sys-fs/vhba/Manifest b/sys-fs/vhba/Manifest
index 989ed2a6113d..35368ad5da1c 100644
--- a/sys-fs/vhba/Manifest
+++ b/sys-fs/vhba/Manifest
@@ -1 +1,2 @@
DIST vhba-module-20190302.tar.bz2 15708 BLAKE2B 4a6f1f22e893597e50e78fa06e1296079b600ad6b2cf7b319267ef44d1ff07795f2aca22541993a7fc57d15550297e71046ce4147226d0731aa2b4d691dd5299 SHA512 6df59112b9b0597ce98de85744acd8158dbc015841740649fa3538fec32f1d7cbf4e489062998cc13dc85a1b3558bcffc2ea65285e17ee5b3f1c0a7d49cd6a38
+DIST vhba-module-20190410.tar.bz2 15741 BLAKE2B 6d513877c771b1c4c5805231cf8bb13333d29dd3c6de7d91879ef1898fdc424df026b0835a772f398dcdc7d8900db462164a40e46c9b66b38ed70f5b5f6a0e7e SHA512 e4b30bea8464d8ac24fd2fddca9d41052af2f5b3dc9e054ead47991bff41366be377600075627c40261722c88c20ed2eaf65fa7afb34690ef09a6f4ea6f9351f
diff --git a/sys-fs/vhba/vhba-20190410.ebuild b/sys-fs/vhba/vhba-20190410.ebuild
new file mode 100644
index 000000000000..8969ab8b663f
--- /dev/null
+++ b/sys-fs/vhba/vhba-20190410.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit eutils linux-mod udev
+
+MY_P=vhba-module-${PV}
+DESCRIPTION="Virtual (SCSI) Host Bus Adapter kernel module for the CDEmu suite"
+HOMEPAGE="http://cdemu.org"
+SRC_URI="mirror://sourceforge/cdemu/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="virtual/udev"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+MODULE_NAMES="vhba(block:${S})"
+BUILD_TARGETS=modules
+
+pkg_setup() {
+ CONFIG_CHECK="~BLK_DEV_SR ~CHR_DEV_SG"
+ check_extra_config
+ BUILD_PARAMS="KDIR=${KV_OUT_DIR}"
+ linux-mod_pkg_setup
+}
+
+src_prepare() {
+ # Avoid "make jobserver unavailable" warning and -Werror problems
+ sed -e '/ccflags/s/-Werror$/-Wall/' \
+ -i Makefile || die "sed failed"
+
+ eapply_user
+}
+
+src_install() {
+ dodoc AUTHORS ChangeLog README
+ linux-mod_src_install
+
+ einfo "Generating udev rules ..."
+ dodir "$(get_udevdir)"/rules.d
+ cat > "${D}/$(get_udevdir)"/rules.d/69-vhba.rules <<-EOF || die
+ # do not edit this file, it will be overwritten on update
+ #
+ KERNEL=="vhba_ctl", SUBSYSTEM=="misc", TAG+="uaccess"
+ EOF
+}
+
+pkg_postinst() {
+ # Older versions of vhba installed their rule file in /etc/udev/rules.d,
+ # which overrides rules in /lib/udev/rules.d. We remove the old file
+ # automatically if it is identical to the default one installed by
+ # vhba-1.2.1 or 20101015-r1. Note that the comment at the top of the rules
+ # file states that it can be automatically overwritten by the system.
+ old_rules="${ROOT}etc/udev/rules.d/70-vhba.rules"
+ if [[ -f "${old_rules}" ]]; then
+ case "$(md5sum ${old_rules})" in
+ 2959b3cf61cfe6e466cc3516a7bc19de* | 1e7a7e5d6d28c811eeec98ec26ed5d28* )
+ elog
+ elog "Removing old ${old_rules} ..."
+ rm -f "${old_rules}" ||
+ eerror "Failed, please remove ${old_rules} manually."
+ ;;
+ * )
+ ewarn
+ ewarn "The ${old_rules} file from a previous"
+ ewarn "installation of ${PN} is overriding ${P}'s"
+ ewarn "udev rules. Unless you had deliberately customized it,"
+ ewarn "you should remove it."
+ ewarn
+ ;;
+ esac
+ fi
+
+ linux-mod_pkg_postinst
+}