summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2021-12-18 12:28:01 -0800
committerZac Medico <zmedico@gentoo.org>2021-12-18 12:31:18 -0800
commit891a8a03d8f12be82c33953bbc789dd24b66369c (patch)
treecf2432e0f72a26542c92f4a3445541b24542f131 /sys-fabric
parentdev-ada/gnatcoll-bindings: fix rm when asked to build nothing (diff)
downloadgentoo-891a8a03d8f12be82c33953bbc789dd24b66369c.tar.gz
gentoo-891a8a03d8f12be82c33953bbc789dd24b66369c.tar.bz2
gentoo-891a8a03d8f12be82c33953bbc789dd24b66369c.zip
sys-fabric/mstflint: Bump to version 4.18.0_p1
Closes: https://bugs.gentoo.org/829507 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'sys-fabric')
-rw-r--r--sys-fabric/mstflint/Manifest1
-rw-r--r--sys-fabric/mstflint/mstflint-4.18.0_p1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/sys-fabric/mstflint/Manifest b/sys-fabric/mstflint/Manifest
index a779f53f9aaf..b7b4244783ac 100644
--- a/sys-fabric/mstflint/Manifest
+++ b/sys-fabric/mstflint/Manifest
@@ -3,3 +3,4 @@ DIST mstflint-4.11.0_p5.tar.gz 3622665 BLAKE2B 119d1ca04eaf3ebc2e4b8175525fdc870
DIST mstflint-4.13.3_p2.tar.gz 3809937 BLAKE2B bfe0d5a531a26547779f2e9377c4c6f393c28623d56c87a1f0210a0fbb767a43f5186c481609722ef2e5066bcdf0110009468b047ca0a8b25c096f4802b43229 SHA512 bd7e937eaed30c4b4479c3bc184d9bd8edff9aba23824fdd6a82f0e62d319854aa74954c783eb483074e322eec94f9a0cd5bd6a0ff4de2422f9b011680324706
DIST mstflint-4.14.0_p3.tar.gz 4012564 BLAKE2B 4203c398665cbc7a0e9f86158e58270c903f546372aecf697c09b75f7fc44944304a4c5f1524362d442ed8e16f5dd9f35fe08ec638c5c556ed182cbac9f1c27b SHA512 c27872e34443df24fb152f2837d2fa31a7a459eff859654d00c815fc942182dc48d18991e83b79cc99bbd5fafe5b721b69e9bee9c927e2d54581eb78d7a5548e
DIST mstflint-4.16.0_p2.tar.gz 4534457 BLAKE2B c199cd0b4eed8ecc20b8ab89235035b7ad258fe583c464dafb31a1e5ba8f6cfd745b132ff12631fa0d98c2d94f16ca69c908c0b6ad94391ec1a3e56ba9967d59 SHA512 03a6b055384b9fab44a31ba6f2de02d1580e08af981c1cad5111a96279872ea960024bfa9debbbdb36019b88713906c3c59d3910a11f169ad5f3a0090bc6c7df
+DIST mstflint-4.18.0_p1.tar.gz 4877851 BLAKE2B 7fb995561155ccc73b0c36d2994c0398483a92788c5ce045f0263a3e5b0ff7230ca8bb0f5b821e957d5879e0629f11716b179e3bc581849335cc95715631c1d6 SHA512 aed2302dc88b9b95892eb6dd929a922ac6257ddae808db656c7fd01c393f9f0a0d3aa4e13da6c07fe0118cd48a43795f39cc16e619408b05e6bed7d085dbf0d4
diff --git a/sys-fabric/mstflint/mstflint-4.18.0_p1.ebuild b/sys-fabric/mstflint/mstflint-4.18.0_p1.ebuild
new file mode 100644
index 000000000000..642fdcf4600f
--- /dev/null
+++ b/sys-fabric/mstflint/mstflint-4.18.0_p1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Mstflint - an open source version of MFT (Mellanox Firmware Tools)"
+HOMEPAGE="https://github.com/Mellanox/mstflint"
+LICENSE="|| ( GPL-2 BSD-2 )"
+KEYWORDS="~amd64 ~x86"
+EGIT_COMMIT="ab6f72086a2aa3a07629536fa091141f40a6f0c0"
+MY_PV=${PV/_p/-}
+MY_P=""
+SRC_URI="https://github.com/Mellanox/mstflint/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+IUSE="adb-generic-tools inband ssl"
+SLOT="0"
+RDEPEND="dev-db/sqlite:3=
+ sys-libs/zlib:=
+ inband? ( sys-fabric/libibmad )
+ adb-generic-tools? (
+ dev-libs/boost:=
+ dev-libs/expat:=
+ )
+ ssl? ( dev-libs/openssl:= )"
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ default
+ echo '#define TOOLS_GIT_SHA "'${EGIT_COMMIT}'"' > ./common/gitversion.h || die
+}
+
+src_configure() {
+ eautoreconf
+ econf $(use_enable inband) $(use_enable ssl openssl) $(use adb-generic-tools && printf -- '--enable-adb-generic-tools')
+}
+
+src_compile() {
+ if use adb-generic-tools; then
+ pushd ext_libs/json >/dev/null || die
+ emake
+ popd >/dev/null || die
+ fi
+ default
+}