summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-09-24 23:20:00 +0100
committerSam James <sam@gentoo.org>2023-09-24 23:25:15 +0100
commit04c3650f36e7818014ddae66fc464cec1593c031 (patch)
tree982cd4a076999554ea8ec6fb49860e0803ad476d /sys-devel
parentsys-devel/crosstool-ng: drop 1.24.0-r1, 1.26.0_rc1 (diff)
downloadgentoo-04c3650f36e7818014ddae66fc464cec1593c031.tar.gz
gentoo-04c3650f36e7818014ddae66fc464cec1593c031.tar.bz2
gentoo-04c3650f36e7818014ddae66fc464cec1593c031.zip
sys-devel/crosstool-ng: style tweaks
Mostly to conform with skel.ebuild. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/crosstool-ng/crosstool-ng-1.24.0-r2.ebuild18
-rw-r--r--sys-devel/crosstool-ng/crosstool-ng-1.25.0.ebuild18
-rw-r--r--sys-devel/crosstool-ng/crosstool-ng-1.26.0_rc2.ebuild18
-rw-r--r--sys-devel/crosstool-ng/crosstool-ng-9999.ebuild18
4 files changed, 40 insertions, 32 deletions
diff --git a/sys-devel/crosstool-ng/crosstool-ng-1.24.0-r2.ebuild b/sys-devel/crosstool-ng/crosstool-ng-1.24.0-r2.ebuild
index e9a93b214563..2e09d5c02c72 100644
--- a/sys-devel/crosstool-ng/crosstool-ng-1.24.0-r2.ebuild
+++ b/sys-devel/crosstool-ng/crosstool-ng-1.24.0-r2.ebuild
@@ -1,23 +1,24 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="8"
+EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
inherit python-single-r1
+DESCRIPTION="Versatile (cross-)toolchain generator"
HOMEPAGE="https://crosstool-ng.github.io/"
-DESCRIPTION="A versatile (cross-)toolchain generator."
-if [[ "${PV}" == 9999 ]] ; then
+if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://github.com/crosstool-ng/crosstool-ng.git"
inherit git-r3
else
SRC_URI="
-https://github.com/crosstool-ng/crosstool-ng/releases/download/${PN}-${PV/_rc/-rc}/${P}.tar.xz
-http://crosstool-ng.org/download/crosstool-ng/${P}.tar.xz
-"
- if [[ "${PV}" != *_rc* ]] ; then
+ https://github.com/crosstool-ng/crosstool-ng/releases/download/${PN}-${PV/_rc/-rc}/${P}.tar.xz
+ http://crosstool-ng.org/download/crosstool-ng/${P}.tar.xz
+ "
+
+ if [[ ${PV} != *_rc* ]] ; then
KEYWORDS="~amd64 ~x86"
fi
fi
@@ -49,15 +50,16 @@ BDEPEND="
subversion? ( dev-vcs/subversion )
wget? ( net-misc/wget )
"
-
RDEPEND="
${BDEPEND}
"
src_install() {
emake DESTDIR="${D}" install
+
use doc && mv "${D}/usr/share/doc/crosstool-ng/crosstool-ng-${PVR}" \
"${D}"/usr/share/doc/
+
rm -rf "${D}"/usr/share/doc/crosstool-ng
rm -rf "${D}/usr/share/man/man1/ct-ng.1.gz"
cp docs/ct-ng.1 "${D}/usr/share/man/man1/"
diff --git a/sys-devel/crosstool-ng/crosstool-ng-1.25.0.ebuild b/sys-devel/crosstool-ng/crosstool-ng-1.25.0.ebuild
index e9a93b214563..2e09d5c02c72 100644
--- a/sys-devel/crosstool-ng/crosstool-ng-1.25.0.ebuild
+++ b/sys-devel/crosstool-ng/crosstool-ng-1.25.0.ebuild
@@ -1,23 +1,24 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="8"
+EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
inherit python-single-r1
+DESCRIPTION="Versatile (cross-)toolchain generator"
HOMEPAGE="https://crosstool-ng.github.io/"
-DESCRIPTION="A versatile (cross-)toolchain generator."
-if [[ "${PV}" == 9999 ]] ; then
+if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://github.com/crosstool-ng/crosstool-ng.git"
inherit git-r3
else
SRC_URI="
-https://github.com/crosstool-ng/crosstool-ng/releases/download/${PN}-${PV/_rc/-rc}/${P}.tar.xz
-http://crosstool-ng.org/download/crosstool-ng/${P}.tar.xz
-"
- if [[ "${PV}" != *_rc* ]] ; then
+ https://github.com/crosstool-ng/crosstool-ng/releases/download/${PN}-${PV/_rc/-rc}/${P}.tar.xz
+ http://crosstool-ng.org/download/crosstool-ng/${P}.tar.xz
+ "
+
+ if [[ ${PV} != *_rc* ]] ; then
KEYWORDS="~amd64 ~x86"
fi
fi
@@ -49,15 +50,16 @@ BDEPEND="
subversion? ( dev-vcs/subversion )
wget? ( net-misc/wget )
"
-
RDEPEND="
${BDEPEND}
"
src_install() {
emake DESTDIR="${D}" install
+
use doc && mv "${D}/usr/share/doc/crosstool-ng/crosstool-ng-${PVR}" \
"${D}"/usr/share/doc/
+
rm -rf "${D}"/usr/share/doc/crosstool-ng
rm -rf "${D}/usr/share/man/man1/ct-ng.1.gz"
cp docs/ct-ng.1 "${D}/usr/share/man/man1/"
diff --git a/sys-devel/crosstool-ng/crosstool-ng-1.26.0_rc2.ebuild b/sys-devel/crosstool-ng/crosstool-ng-1.26.0_rc2.ebuild
index e9a93b214563..2e09d5c02c72 100644
--- a/sys-devel/crosstool-ng/crosstool-ng-1.26.0_rc2.ebuild
+++ b/sys-devel/crosstool-ng/crosstool-ng-1.26.0_rc2.ebuild
@@ -1,23 +1,24 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="8"
+EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
inherit python-single-r1
+DESCRIPTION="Versatile (cross-)toolchain generator"
HOMEPAGE="https://crosstool-ng.github.io/"
-DESCRIPTION="A versatile (cross-)toolchain generator."
-if [[ "${PV}" == 9999 ]] ; then
+if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://github.com/crosstool-ng/crosstool-ng.git"
inherit git-r3
else
SRC_URI="
-https://github.com/crosstool-ng/crosstool-ng/releases/download/${PN}-${PV/_rc/-rc}/${P}.tar.xz
-http://crosstool-ng.org/download/crosstool-ng/${P}.tar.xz
-"
- if [[ "${PV}" != *_rc* ]] ; then
+ https://github.com/crosstool-ng/crosstool-ng/releases/download/${PN}-${PV/_rc/-rc}/${P}.tar.xz
+ http://crosstool-ng.org/download/crosstool-ng/${P}.tar.xz
+ "
+
+ if [[ ${PV} != *_rc* ]] ; then
KEYWORDS="~amd64 ~x86"
fi
fi
@@ -49,15 +50,16 @@ BDEPEND="
subversion? ( dev-vcs/subversion )
wget? ( net-misc/wget )
"
-
RDEPEND="
${BDEPEND}
"
src_install() {
emake DESTDIR="${D}" install
+
use doc && mv "${D}/usr/share/doc/crosstool-ng/crosstool-ng-${PVR}" \
"${D}"/usr/share/doc/
+
rm -rf "${D}"/usr/share/doc/crosstool-ng
rm -rf "${D}/usr/share/man/man1/ct-ng.1.gz"
cp docs/ct-ng.1 "${D}/usr/share/man/man1/"
diff --git a/sys-devel/crosstool-ng/crosstool-ng-9999.ebuild b/sys-devel/crosstool-ng/crosstool-ng-9999.ebuild
index e9a93b214563..2e09d5c02c72 100644
--- a/sys-devel/crosstool-ng/crosstool-ng-9999.ebuild
+++ b/sys-devel/crosstool-ng/crosstool-ng-9999.ebuild
@@ -1,23 +1,24 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="8"
+EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
inherit python-single-r1
+DESCRIPTION="Versatile (cross-)toolchain generator"
HOMEPAGE="https://crosstool-ng.github.io/"
-DESCRIPTION="A versatile (cross-)toolchain generator."
-if [[ "${PV}" == 9999 ]] ; then
+if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://github.com/crosstool-ng/crosstool-ng.git"
inherit git-r3
else
SRC_URI="
-https://github.com/crosstool-ng/crosstool-ng/releases/download/${PN}-${PV/_rc/-rc}/${P}.tar.xz
-http://crosstool-ng.org/download/crosstool-ng/${P}.tar.xz
-"
- if [[ "${PV}" != *_rc* ]] ; then
+ https://github.com/crosstool-ng/crosstool-ng/releases/download/${PN}-${PV/_rc/-rc}/${P}.tar.xz
+ http://crosstool-ng.org/download/crosstool-ng/${P}.tar.xz
+ "
+
+ if [[ ${PV} != *_rc* ]] ; then
KEYWORDS="~amd64 ~x86"
fi
fi
@@ -49,15 +50,16 @@ BDEPEND="
subversion? ( dev-vcs/subversion )
wget? ( net-misc/wget )
"
-
RDEPEND="
${BDEPEND}
"
src_install() {
emake DESTDIR="${D}" install
+
use doc && mv "${D}/usr/share/doc/crosstool-ng/crosstool-ng-${PVR}" \
"${D}"/usr/share/doc/
+
rm -rf "${D}"/usr/share/doc/crosstool-ng
rm -rf "${D}/usr/share/man/man1/ct-ng.1.gz"
cp docs/ct-ng.1 "${D}/usr/share/man/man1/"