summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-07-03 02:40:29 +0100
committerSam James <sam@gentoo.org>2024-07-03 02:40:29 +0100
commitbf9cbb53ac91ce4d3568f7bb51ebc6703f4ead32 (patch)
treee97b3f23494b4ab1ab6d7f0eb3dd55bef73b91eb /sys-devel/mold/files
parentdev-build/cmake: add 3.29.6 (diff)
downloadgentoo-bf9cbb53ac91ce4d3568f7bb51ebc6703f4ead32.tar.gz
gentoo-bf9cbb53ac91ce4d3568f7bb51ebc6703f4ead32.tar.bz2
gentoo-bf9cbb53ac91ce4d3568f7bb51ebc6703f4ead32.zip
sys-devel/mold: add 2.32.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel/mold/files')
-rw-r--r--sys-devel/mold/files/mold-2.32.1-libdl.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/sys-devel/mold/files/mold-2.32.1-libdl.patch b/sys-devel/mold/files/mold-2.32.1-libdl.patch
new file mode 100644
index 000000000000..994137938b68
--- /dev/null
+++ b/sys-devel/mold/files/mold-2.32.1-libdl.patch
@@ -0,0 +1,20 @@
+https://github.com/rui314/mold/commit/091395df335d577adc2a09e854a129f02081c576
+
+From 091395df335d577adc2a09e854a129f02081c576 Mon Sep 17 00:00:00 2001
+From: Rui Ueyama <ruiu@cs.stanford.edu>
+Date: Fri, 28 Jun 2024 11:00:36 +0900
+Subject: [PATCH] Link with `-ldl` for dlopen()
+
+Fixes https://github.com/rui314/mold/issues/1293
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -61,6 +61,8 @@ target_compile_features(mold PRIVATE cxx_std_20)
+
+ if(MINGW)
+ target_link_libraries(mold PRIVATE dl)
++else()
++ target_link_libraries(mold PRIVATE ${CMAKE_DL_LIBS})
+ endif()
+
+ if(NOT "${CMAKE_CXX_COMPILER_FRONTEND_VARIANT}" STREQUAL "MSVC")
+