summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-02-10 17:24:17 +0100
committerMichał Górny <mgorny@gentoo.org>2016-02-10 17:27:23 +0100
commit735863828c34908baf4c6a2425db0c4f0538ff55 (patch)
treeaabef9a0324e491840063e715626d9f9b7c38917 /sys-devel/llvm/llvm-3.7.1.ebuild
parentMerge remote-tracking branch 'github/pr/830'. (diff)
downloadgentoo-735863828c34908baf4c6a2425db0c4f0538ff55.tar.gz
gentoo-735863828c34908baf4c6a2425db0c4f0538ff55.tar.bz2
gentoo-735863828c34908baf4c6a2425db0c4f0538ff55.zip
sys-devel/llvm: Remove unnecessary revbump due to FreeBSD-related change
The FreeBSD header change does not justify forcing rebuild of such a huge package as LLVM on Linux. Furthermore, the new code relies on a new USE flag, so FreeBSD users will get it via --changed-use.
Diffstat (limited to 'sys-devel/llvm/llvm-3.7.1.ebuild')
-rw-r--r--sys-devel/llvm/llvm-3.7.1.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/sys-devel/llvm/llvm-3.7.1.ebuild b/sys-devel/llvm/llvm-3.7.1.ebuild
index e4697d0e7917..2dbd2e5e16fa 100644
--- a/sys-devel/llvm/llvm-3.7.1.ebuild
+++ b/sys-devel/llvm/llvm-3.7.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -23,7 +23,8 @@ LICENSE="UoI-NCSA"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="clang debug doc gold libedit +libffi lldb multitarget ncurses ocaml
- python +static-analyzer test xml video_cards_radeon kernel_Darwin"
+ python +static-analyzer test xml video_cards_radeon
+ kernel_Darwin kernel_FreeBSD"
COMMON_DEPEND="
sys-libs/zlib:0=
@@ -430,6 +431,9 @@ src_install() {
fi
multilib-minimal_src_install
+
+ # Remove unnecessary headers on FreeBSD, bug #417171
+ use kernel_FreeBSD && use clang && rm "${ED}"usr/lib/clang/${PV}/include/{std,float,iso,limits,tgmath,varargs}*.h
}
multilib_src_install() {