summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-08-22 15:43:14 +0200
committerMichał Górny <mgorny@gentoo.org>2016-08-22 17:11:50 +0200
commit11d093e4ec16f42e733d605dccf3100d4bb435ba (patch)
tree430bb5398c01766b2874e1226a187749ffa98f69 /sys-devel/llvm/llvm-3.5.2.ebuild
parentsys-devel/clang: Enable stand-alone builds against sys-devel/llvm (diff)
downloadgentoo-11d093e4ec16f42e733d605dccf3100d4bb435ba.tar.gz
gentoo-11d093e4ec16f42e733d605dccf3100d4bb435ba.tar.bz2
gentoo-11d093e4ec16f42e733d605dccf3100d4bb435ba.zip
sys-devel/llvm: Group all patches by newest version applicable
Diffstat (limited to 'sys-devel/llvm/llvm-3.5.2.ebuild')
-rw-r--r--sys-devel/llvm/llvm-3.5.2.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/sys-devel/llvm/llvm-3.5.2.ebuild b/sys-devel/llvm/llvm-3.5.2.ebuild
index 6d3a5ce61fc8..e158a2d87306 100644
--- a/sys-devel/llvm/llvm-3.5.2.ebuild
+++ b/sys-devel/llvm/llvm-3.5.2.ebuild
@@ -144,19 +144,19 @@ src_unpack() {
}
src_prepare() {
- epatch "${FILESDIR}"/${PN}-3.2-nodoctargz.patch
- epatch "${FILESDIR}"/${PN}-3.5-gcc-4.9.patch
- epatch "${FILESDIR}"/${PN}-3.5-gentoo-install.patch
- epatch "${FILESDIR}"/${P}-gcc-5.1.patch
+ epatch "${FILESDIR}"/3.6.2/nodoctargz.patch
+ epatch "${FILESDIR}"/3.6.2/gcc-4.9.patch
+ epatch "${FILESDIR}"/3.5.2/gentoo-install.patch
+ epatch "${FILESDIR}"/3.5.2/gcc-5.1.patch
# Make ocaml warnings non-fatal, bug #537308
sed -e "/RUN/s/-warn-error A//" -i test/Bindings/Ocaml/*ml || die
if use clang; then
# Automatically select active system GCC's libraries, bugs #406163 and #417913
- epatch "${FILESDIR}"/clang-3.5-gentoo-runtime-gcc-detection-v3.patch
+ epatch "${FILESDIR}"/3.8.1/clang/gentoo-runtime-gcc-detection-v3.patch
- epatch "${FILESDIR}"/clang-3.5-gentoo-install.patch
- epatch "${FILESDIR}"/clang-3.4-darwin_prefix-include-paths.patch
+ epatch "${FILESDIR}"/3.5.2/clang/gentoo-install.patch
+ epatch "${FILESDIR}"/3.8.1/clang/darwin_prefix-include-paths.patch
eprefixify tools/clang/lib/Frontend/InitHeaderSearch.cpp
fi