summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-05-29 22:15:43 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-05-29 22:27:33 +0100
commit9cb6f36587c721251c496ebaabd0693fb94cca26 (patch)
tree3d841f0275220aeaf1312c2393ad52dde10409f3 /sys-devel/gcc/gcc-7.5.0-r1.ebuild
parentsys-devel/gcc: 8.4.0: cut 2 patchset (diff)
downloadgentoo-9cb6f36587c721251c496ebaabd0693fb94cca26.tar.gz
gentoo-9cb6f36587c721251c496ebaabd0693fb94cca26.tar.bz2
gentoo-9cb6f36587c721251c496ebaabd0693fb94cca26.zip
sys-devel/gcc: 7.5.0: cut 3 patchset
One new patch: - 29_all_libcpp-ar.patch: respect user's AR Reported-by: Agostino Sarubbo Bug: https://bugs.gentoo.org/718004 Bug: https://gcc.gnu.org/PR94657 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-devel/gcc/gcc-7.5.0-r1.ebuild')
-rw-r--r--sys-devel/gcc/gcc-7.5.0-r1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-7.5.0-r1.ebuild b/sys-devel/gcc/gcc-7.5.0-r1.ebuild
new file mode 100644
index 000000000000..779dc5475441
--- /dev/null
+++ b/sys-devel/gcc/gcc-7.5.0-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PATCH_VER="3"
+
+inherit toolchain
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-macos"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ elibc_glibc? ( >=sys-libs/glibc-2.13 )
+ >=${CATEGORY}/binutils-2.20"
+
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.13 )"
+fi