summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-13 21:20:50 +0100
committerSam James <sam@gentoo.org>2022-04-13 22:43:06 +0100
commitce2fd800cd4370d759de70932cd5a5f2a15fc599 (patch)
treeab59389d4bcc61a758d38eb00d406f0716ac553f /sys-devel/clang-runtime
parentsys-libs/libomp: Bump to 14.0.1 (diff)
downloadgentoo-ce2fd800cd4370d759de70932cd5a5f2a15fc599.tar.gz
gentoo-ce2fd800cd4370d759de70932cd5a5f2a15fc599.tar.bz2
gentoo-ce2fd800cd4370d759de70932cd5a5f2a15fc599.zip
sys-devel/clang-runtime: Bump to 14.0.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel/clang-runtime')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-14.0.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-14.0.1.ebuild b/sys-devel/clang-runtime/clang-runtime-14.0.1.ebuild
new file mode 100644
index 000000000000..e02d928d2be4
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-14.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="metapackage"
+SLOT="$(ver_cut 1-3)"
+KEYWORDS=""
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+PROPERTIES="live"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ sanitize? (
+ ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"