summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2021-02-28 11:40:08 +0000
committerPatrick Lauer <patrick@gentoo.org>2021-02-28 11:40:08 +0000
commita4fddb80917ed3cdc011f25c874d8262d159ec84 (patch)
tree110e4e5fa367be1f3d9ba6bb00550c2c0a84a98a /sys-cluster/ucx/ucx-1.9.0.ebuild
parentsys-cluster/openmpi: Bump (diff)
downloadgentoo-a4fddb80917ed3cdc011f25c874d8262d159ec84.tar.gz
gentoo-a4fddb80917ed3cdc011f25c874d8262d159ec84.tar.bz2
gentoo-a4fddb80917ed3cdc011f25c874d8262d159ec84.zip
sys-cluster/ucx: Bump
Fixes #725756 Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'sys-cluster/ucx/ucx-1.9.0.ebuild')
-rw-r--r--sys-cluster/ucx/ucx-1.9.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-cluster/ucx/ucx-1.9.0.ebuild b/sys-cluster/ucx/ucx-1.9.0.ebuild
new file mode 100644
index 000000000000..65a9b0241cf7
--- /dev/null
+++ b/sys-cluster/ucx/ucx-1.9.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Unified Communication X"
+HOMEPAGE="https://www.openucx.org"
+SRC_URI="https://github.com/openucx/ucx/releases/download/v${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+numa +openmp"
+
+RDEPEND="
+ sys-libs/binutils-libs:=
+ numa? ( sys-process/numactl )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ BASE_CFLAGS="" \
+ econf \
+ --disable-compiler-opt \
+ $(use_enable numa) \
+ $(use_enable openmp)
+}
+
+src_compile() {
+ BASE_CFLAGS="" emake
+}