summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-07-14 23:32:40 +0100
committerMarek Szuba <marecki@gentoo.org>2021-07-14 23:45:01 +0100
commit45d83f6dfdeecffefc0939bc41bdf4ecf3685b1d (patch)
tree69549b1d237f0cce3593105c436cae52123f493b /sys-cluster/openmpi/openmpi-2.0.4.ebuild
parentsys-apps/hwloc-1.11.13: update EAPI 6 -> 7 (diff)
downloadgentoo-45d83f6dfdeecffefc0939bc41bdf4ecf3685b1d.tar.gz
gentoo-45d83f6dfdeecffefc0939bc41bdf4ecf3685b1d.tar.bz2
gentoo-45d83f6dfdeecffefc0939bc41bdf4ecf3685b1d.zip
sys-cluster/openmpi: update EAPI 6 -> 7
Interestingly enough both the newest and the *oldest* versions were already EAPI 7, as the latter had been migrated to it directly from 5. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'sys-cluster/openmpi/openmpi-2.0.4.ebuild')
-rw-r--r--sys-cluster/openmpi/openmpi-2.0.4.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/sys-cluster/openmpi/openmpi-2.0.4.ebuild b/sys-cluster/openmpi/openmpi-2.0.4.ebuild
index 39c9e77772d7..93c7bfd018cf 100644
--- a/sys-cluster/openmpi/openmpi-2.0.4.ebuild
+++ b/sys-cluster/openmpi/openmpi-2.0.4.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
FORTRAN_NEEDED=fortran
-inherit cuda flag-o-matic fortran-2 java-pkg-opt-2 toolchain-funcs versionator multilib-minimal
+inherit cuda flag-o-matic fortran-2 java-pkg-opt-2 toolchain-funcs multilib-minimal
MY_P=${P/-mpi}
S=${WORKDIR}/${MY_P}
@@ -29,7 +29,7 @@ IUSE_OPENMPI_OFED_FEATURES="
DESCRIPTION="A high-performance message passing library (MPI)"
HOMEPAGE="https://www.open-mpi.org"
-SRC_URI="https://www.open-mpi.org/software/ompi/v$(get_version_component_range 1-2)/downloads/${MY_P}.tar.bz2"
+SRC_URI="https://www.open-mpi.org/software/ompi/v$(ver_cut 1-2)/downloads/${MY_P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~ia64 ~ppc ~ppc64 sparc x86 ~amd64-linux"
@@ -149,24 +149,27 @@ multilib_src_install() {
# fortran header cannot be wrapped (bug #540508), workaround part 1
if multilib_is_native_abi && use fortran; then
mkdir "${T}"/fortran || die
- mv "${ED}"usr/include/mpif* "${T}"/fortran || die
+ mv "${ED}"/usr/include/mpif* "${T}"/fortran || die
else
# some fortran files get installed unconditionally
- rm "${ED}"usr/include/mpif* "${ED}"usr/bin/mpif* || die
+ rm \
+ "${ED}"/usr/include/mpif* \
+ "${ED}"/usr/bin/mpif* \
+ || die
fi
}
multilib_src_install_all() {
# fortran header cannot be wrapped (bug #540508), workaround part 2
if use fortran; then
- mv "${T}"/fortran/mpif* "${ED}"usr/include || die
+ mv "${T}"/fortran/mpif* "${ED}"/usr/include || die
fi
# Remove la files, no static libs are installed and we have pkg-config
find "${ED}" -name '*.la' -delete || die
if use java; then
- local mpi_jar="${ED}"usr/$(get_libdir)/mpi.jar
+ local mpi_jar="${ED}"/usr/$(get_libdir)/mpi.jar
java-pkg_dojar "${mpi_jar}"
# We don't want to install the jar file twice
# so let's clean after ourselves.