summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2024-08-28 18:07:01 +0300
committerViorel Munteanu <ceamac@gentoo.org>2024-08-28 18:13:59 +0300
commita786643b846ca4f1c12121f3a3a82b47229e8c25 (patch)
tree32af160cae4ad6b16b98562349241f56a732f72b /sys-boot
parentxfce-base/xfdesktop: Add license for backgrounds (diff)
downloadgentoo-a786643b846ca4f1c12121f3a3a82b47229e8c25.tar.gz
gentoo-a786643b846ca4f1c12121f3a3a82b47229e8c25.tar.bz2
gentoo-a786643b846ca4f1c12121f3a3a82b47229e8c25.zip
sys-boot/gnu-efi: fix compilation on different locales
Closes: https://bugs.gentoo.org/938580 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/gnu-efi/gnu-efi-3.0.18-r4.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-boot/gnu-efi/gnu-efi-3.0.18-r4.ebuild b/sys-boot/gnu-efi/gnu-efi-3.0.18-r4.ebuild
index b34d3a74c7db..7185e2dbb78c 100644
--- a/sys-boot/gnu-efi/gnu-efi-3.0.18-r4.ebuild
+++ b/sys-boot/gnu-efi/gnu-efi-3.0.18-r4.ebuild
@@ -42,7 +42,7 @@ check_and_set_objcopy() {
# llvm-objcopy does not support EFI target, try to use binutils objcopy or fail
tc-export OBJCOPY
OBJCOPY="${OBJCOPY/llvm-/}"
- LANG=C LC_ALL=C "${OBJCOPY}" --help | grep -q '\<pei-' || die "${OBJCOPY} (objcopy) does not support EFI target"
+ LC_ALL=C "${OBJCOPY}" --help | grep -q '\<pei-' || die "${OBJCOPY} (objcopy) does not support EFI target"
fi
}
@@ -103,9 +103,9 @@ src_compile() {
# bug #933080, #938012
local CPPINCLUDEDIR
if tc-is-gcc; then
- CPPINCLUDEDIR=$(LANG=C ${CC} -print-search-dirs 2> /dev/null | grep ^install: | cut -f2 -d' ')/include
+ CPPINCLUDEDIR=$(LC_ALL=C ${CC} -print-search-dirs 2> /dev/null | grep ^install: | cut -f2 -d' ')/include
elif tc-is-clang; then
- CPPINCLUDEDIR=$(LANG=C ${CC} -print-resource-dir 2> /dev/null)/include
+ CPPINCLUDEDIR=$(LC_ALL=C ${CC} -print-resource-dir 2> /dev/null)/include
fi
append-cflags "-nostdinc -isystem ${CPPINCLUDEDIR} -isystem ${ESYSROOT}/usr/include"