summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-22 18:41:03 +0100
committerSam James <sam@gentoo.org>2022-04-22 18:43:07 +0100
commit855c59c561e00df4f4d1f32638ea970259bd9976 (patch)
tree43127649c64f30585df500f506ad179a735eff74 /sys-boot
parentapp-portage/cfg-update: fix ROOT check in pkg_postinst (diff)
downloadgentoo-855c59c561e00df4f4d1f32638ea970259bd9976.tar.gz
gentoo-855c59c561e00df4f4d1f32638ea970259bd9976.tar.bz2
gentoo-855c59c561e00df4f4d1f32638ea970259bd9976.zip
sys-boot/lilo: fix ROOT check in pkg_postinst
With EAPI 7+, ROOT and others will be blank (not /). Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/lilo/lilo-24.2-r1.ebuild (renamed from sys-boot/lilo/lilo-24.2.ebuild)4
1 files changed, 2 insertions, 2 deletions
diff --git a/sys-boot/lilo/lilo-24.2.ebuild b/sys-boot/lilo/lilo-24.2-r1.ebuild
index 9ae96a087bd0..66040236a6d6 100644
--- a/sys-boot/lilo/lilo-24.2.ebuild
+++ b/sys-boot/lilo/lilo-24.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -162,7 +162,7 @@ pkg_postinst() {
ln -snf boot-menu.b "${ROOT}/boot/boot.b"
fi
- if [ "${ROOT}" = "/" ] && use !minimal;
+ if [[ -z "${ROOT}" ]] && use !minimal;
then
if lilocheck
then