summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-04-20 21:58:43 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-04-20 22:04:24 +0300
commit75e422808b505c761082787358af97a1a68d6045 (patch)
treee7c0f52745e8ce92f95705f9634d97bce7fdb8cb /sys-block/blktrace
parentdev-tcltk/thread: implicit function declarations (diff)
downloadgentoo-75e422808b505c761082787358af97a1a68d6045.tar.gz
gentoo-75e422808b505c761082787358af97a1a68d6045.tar.bz2
gentoo-75e422808b505c761082787358af97a1a68d6045.zip
sys-block/blktrace: EAPI 6 -> 8
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'sys-block/blktrace')
-rw-r--r--sys-block/blktrace/blktrace-1.3.0-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-block/blktrace/blktrace-1.3.0-r1.ebuild b/sys-block/blktrace/blktrace-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..f894d58430b3
--- /dev/null
+++ b/sys-block/blktrace/blktrace-1.3.0-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs flag-o-matic linux-info
+
+DESCRIPTION="show detailed info about what is happening on a block device io queue"
+HOMEPAGE="https://git.kernel.dk/cgit/blktrace/"
+SRC_URI="https://brick.kernel.dk/snaps/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="doc"
+
+RDEPEND="dev-libs/libaio"
+# This is a Linux specific app!
+DEPEND="${RDEPEND}
+ sys-kernel/linux-headers
+ doc? (
+ virtual/latex-base
+ >=app-text/texlive-core-2014
+ )
+"
+
+CONFIG_CHECK="~BLK_DEV_IO_TRACE"
+WARNING_BLK_DEV_IO_TRACE="you need to enable BLK_DEV_IO_TRACE kernel option if you want to gather traces from this machine"
+
+src_compile() {
+ append-cppflags -DLVM_REMAP_WORKAROUND -W -I"${S}"
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} ${CPPFLAGS}"
+ if use doc; then
+ export VARTEXFONTS="${T}/fonts"
+ emake docs
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${ED}" prefix="/usr" mandir="/usr/share/man"
+ einstalldocs
+ use doc && dodoc doc/blktrace.pdf btt/doc/btt.pdf
+}