summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2019-08-18 17:57:35 -0400
committerMike Gilbert <floppym@gentoo.org>2019-08-18 17:58:08 -0400
commite6f565c38efb10d21de27c82ef3713eb8f6aa962 (patch)
tree6a3d5b4a63ba2c762df4bdb22a45f42b9552fbd3 /sys-apps
parentdev-lang/python-exec: amd64 stable wrt bug #692186 (diff)
downloadgentoo-e6f565c38efb10d21de27c82ef3713eb8f6aa962.tar.gz
gentoo-e6f565c38efb10d21de27c82ef3713eb8f6aa962.tar.bz2
gentoo-e6f565c38efb10d21de27c82ef3713eb8f6aa962.zip
sys-apps/hwids: bump to 20190818
Package-Manager: Portage-2.3.71_p6, Repoman-2.3.17_p5 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/hwids/Manifest1
-rw-r--r--sys-apps/hwids/hwids-20190818.ebuild91
-rw-r--r--sys-apps/hwids/hwids-99999999.ebuild11
3 files changed, 97 insertions, 6 deletions
diff --git a/sys-apps/hwids/Manifest b/sys-apps/hwids/Manifest
index 337532012461..9cd679929afd 100644
--- a/sys-apps/hwids/Manifest
+++ b/sys-apps/hwids/Manifest
@@ -1,3 +1,4 @@
DIST hwids-20171003.tar.gz 3035908 BLAKE2B 8ecce99f6a6233b3dd79e1663053b6718fd8b4975a02e5735c1b8483214193bcd45a606145a7709f0b9021dd69e0757361bd568f4ba2d66a52641f691aa7f50a SHA512 6a05963f1883cfeb774671931a32eb9322ead145d4d8aa2fa791e90fc3c823a0b3baeaaa4ce84de0e6a10dcd7f1b5943f6d2cab8790d21e8f34ca1d403598a8a
DIST hwids-20180917.tar.gz 3211960 BLAKE2B d1dc00994a63a6cb6f7c41c73267dcc38b59a46b9e627fac9d6df285b8d1abf5d1335c02c047bff2b09c9ed9f8e4a1c79329c1bd7dd932949d3db2bbb5b9b2e6 SHA512 9fdcd5a7b3adca1bed886aa83e9cf3944391a819fc9f09b673bd815d95e6e70cecf40d8e87287207e34bfeb58c888188fc61b1c0ac13c1ecab0efbdb5100f8d9
DIST hwids-20190316.tar.gz 3312959 BLAKE2B d9f4c7170979c404a69ca0b51903af34db01a6150ec70dc1416dcb507dfa4d8ad9ce325204791a24e5646dee67aea0c1566c15dcddb65a5d9dddbbbb9b896398 SHA512 6db50577b5d29d73f1dc0a44d0b74320cb0df186b9850160b15a6e8f2bcbdbf8193bae4146f81a5afc6b0e05706b5286b4b5858eb028d6c58ea4582df61d232e
+DIST hwids-20190818.tar.gz 3407208 BLAKE2B c2a0098cba4a34210461a2781f325a95f18696c1917ff3a1c26a2f56383e9edd087ab6b3a1a173a92df829fc250cf460d915a98298f9c38a71396bf232916245 SHA512 74086f96152482af3c9caabc729f34d193cc619aae88d44aa0472d674b7533ab806b13243c95bfa04417bdd40e3bb7069b766c2c0824f19d0c62385b043a01c2
diff --git a/sys-apps/hwids/hwids-20190818.ebuild b/sys-apps/hwids/hwids-20190818.ebuild
new file mode 100644
index 000000000000..fc424a668c7f
--- /dev/null
+++ b/sys-apps/hwids/hwids-20190818.ebuild
@@ -0,0 +1,91 @@
+# Copyright 2012-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit udev
+
+DESCRIPTION="Hardware (PCI, USB, OUI, IAB) IDs databases"
+HOMEPAGE="https://github.com/gentoo/hwids"
+if [[ ${PV} == 99999999 ]]; then
+ PYTHON_COMPAT=( python3_{6,7} )
+ inherit git-r3 python-any-r1
+ EGIT_REPO_URI="${HOMEPAGE}.git"
+else
+ SRC_URI="${HOMEPAGE}/archive/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="|| ( GPL-2 BSD ) public-domain"
+SLOT="0"
+IUSE="+net +pci +udev +usb"
+
+RDEPEND="
+ udev? ( virtual/udev )
+ !<sys-apps/pciutils-3.1.9-r2
+ !<sys-apps/usbutils-005-r1
+"
+
+if [[ ${PV} == 99999999 ]]; then
+ BDEPEND="
+ net-misc/curl
+ udev? ( $(python_gen_any_dep 'dev-python/pyparsing[${PYTHON_USEDEP}]') )
+ "
+ python_check_deps() {
+ if use udev; then
+ has_version -b "dev-python/pyparsing[${PYTHON_USEDEP}]"
+ fi
+ }
+else
+ S=${WORKDIR}/hwids-${P}
+fi
+
+pkg_setup() {
+ :
+}
+
+src_unpack() {
+ if [[ ${PV} == 99999999 ]]; then
+ git-r3_src_unpack
+ cd "${S}" || die
+ emake fetch
+ else
+ default
+ fi
+}
+
+src_prepare() {
+ default
+ sed -i -e '/udevadm hwdb/d' Makefile || die
+}
+
+_emake() {
+ emake \
+ NET=$(usex net) \
+ PCI=$(usex pci) \
+ UDEV=$(usex udev) \
+ USB=$(usex usb) \
+ "$@"
+}
+
+src_compile() {
+ if [[ ${PV} == 99999999 ]] && use udev; then
+ python_setup
+ _emake udev-hwdb
+ fi
+ _emake
+}
+
+src_install() {
+ _emake install \
+ DOCDIR="${EPREFIX}/usr/share/doc/${PF}" \
+ MISCDIR="${EPREFIX}/usr/share/misc" \
+ HWDBDIR="${EPREFIX}$(get_udevdir)/hwdb.d" \
+ DESTDIR="${D}"
+}
+
+pkg_postinst() {
+ if use udev; then
+ udevadm hwdb --update --root="${ROOT}"
+ fi
+}
diff --git a/sys-apps/hwids/hwids-99999999.ebuild b/sys-apps/hwids/hwids-99999999.ebuild
index 17e5beb8c711..fc424a668c7f 100644
--- a/sys-apps/hwids/hwids-99999999.ebuild
+++ b/sys-apps/hwids/hwids-99999999.ebuild
@@ -1,13 +1,13 @@
# Copyright 2012-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=7
inherit udev
DESCRIPTION="Hardware (PCI, USB, OUI, IAB) IDs databases"
HOMEPAGE="https://github.com/gentoo/hwids"
-if [[ ${PV} == "99999999" ]]; then
+if [[ ${PV} == 99999999 ]]; then
PYTHON_COMPAT=( python3_{6,7} )
inherit git-r3 python-any-r1
EGIT_REPO_URI="${HOMEPAGE}.git"
@@ -20,7 +20,6 @@ LICENSE="|| ( GPL-2 BSD ) public-domain"
SLOT="0"
IUSE="+net +pci +udev +usb"
-DEPEND=""
RDEPEND="
udev? ( virtual/udev )
!<sys-apps/pciutils-3.1.9-r2
@@ -28,13 +27,13 @@ RDEPEND="
"
if [[ ${PV} == 99999999 ]]; then
- DEPEND+="
+ BDEPEND="
net-misc/curl
udev? ( $(python_gen_any_dep 'dev-python/pyparsing[${PYTHON_USEDEP}]') )
"
python_check_deps() {
if use udev; then
- has_version --host-root "dev-python/pyparsing[${PYTHON_USEDEP}]"
+ has_version -b "dev-python/pyparsing[${PYTHON_USEDEP}]"
fi
}
else
@@ -87,6 +86,6 @@ src_install() {
pkg_postinst() {
if use udev; then
- udevadm hwdb --update --root="${ROOT%/}"
+ udevadm hwdb --update --root="${ROOT}"
fi
}