summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@gentoo.org>2024-10-24 10:43:06 +0200
committerPetr Vaněk <arkamar@gentoo.org>2024-10-24 11:38:19 +0200
commitdaf7d82df21feb4bd6a910292806116b98a98cd1 (patch)
treece8c06e5193e3eb3da8af0b0b2da134da8d52d33 /sys-apps
parentsys-apps/s6-rc: add 0.5.5.0 (diff)
downloadgentoo-daf7d82df21feb4bd6a910292806116b98a98cd1.tar.gz
gentoo-daf7d82df21feb4bd6a910292806116b98a98cd1.tar.bz2
gentoo-daf7d82df21feb4bd6a910292806116b98a98cd1.zip
sys-apps/s6-portable-utils: add 2.3.0.4
Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/s6-portable-utils/Manifest1
-rw-r--r--sys-apps/s6-portable-utils/s6-portable-utils-2.3.0.4.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/sys-apps/s6-portable-utils/Manifest b/sys-apps/s6-portable-utils/Manifest
index 5c74fce4b105..acd2fc278d4b 100644
--- a/sys-apps/s6-portable-utils/Manifest
+++ b/sys-apps/s6-portable-utils/Manifest
@@ -1 +1,2 @@
DIST s6-portable-utils-2.3.0.3.tar.gz 51186 BLAKE2B 9a0b9f33a89cca730afc8190ab7be7fc25ed286970b430d33d8eb91d5b6e5ac4261e659674ec44c5e5a88b32a324cb62ee63837923f0a7481675c8eaa3e8804c SHA512 f75242ac6c06ffd5bd66b8a35bbdf39938cf3bfa6e79abd214af37e9e4acc732ca1760566862482bc964a5cca05bbce8bd24d7167b02dc66c5f397c85ee0d37f
+DIST s6-portable-utils-2.3.0.4.tar.gz 51121 BLAKE2B 7b6ad87ba07f99f0b7b1bf32f966d9a45c0c4aca51b37271136c13c0f2e655c95e850189ec8b210ef0878e89916fc6b1f1e6afd30451462598d98afeec7bcd5d SHA512 0da4fb637f414d870e0476a01c08448b021d2c20c9a4746ab1c6c700e8eeb055d57f6e8326228694463483cd307e308f8fe148a615232039f32dcf351d5060ec
diff --git a/sys-apps/s6-portable-utils/s6-portable-utils-2.3.0.4.ebuild b/sys-apps/s6-portable-utils/s6-portable-utils-2.3.0.4.ebuild
new file mode 100644
index 000000000000..c342cbb05383
--- /dev/null
+++ b/sys-apps/s6-portable-utils/s6-portable-utils-2.3.0.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature toolchain-funcs
+
+DESCRIPTION="Set of tiny portable unix utilities"
+HOMEPAGE="https://www.skarnet.org/software/s6-portable-utils/"
+SRC_URI="https://www.skarnet.org/software/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND=">=dev-libs/skalibs-2.14.0.0:="
+DEPEND="${RDEPEND}"
+
+HTML_DOCS=( doc/. )
+
+src_prepare() {
+ default
+
+ # Avoid QA warning for LDFLAGS addition
+ sed -i -e 's/.*-Wl,--hash-style=both$/:/' configure || die
+
+ sed -i -e '/AR := /d' -e '/RANLIB := /d' Makefile || die
+}
+
+src_configure() {
+ tc-export AR CC RANLIB
+
+ local myconf=(
+ --bindir=/bin
+ --dynlibdir="/$(get_libdir)"
+ --libdir="/usr/$(get_libdir)/${PN}"
+ --with-dynlib="/$(get_libdir)"
+ --with-lib="/usr/$(get_libdir)/skalibs"
+ --with-sysdeps="/usr/$(get_libdir)/skalibs"
+ --disable-allstatic
+ --disable-static
+ --disable-static-libc
+ )
+
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ optfeature "man pages" app-doc/s6-portable-utils-man-pages
+}