summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-26 11:39:40 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-26 20:24:21 +0200
commitcc7fabab6e85bfa0db57112f95e3b9f007f6aff3 (patch)
treede2440b10c59d6c5fb416899bd5278442e42f639 /sys-apps
parentsci-physics/lammps: enable py3.9, enable py3.10 (diff)
downloadgentoo-cc7fabab6e85bfa0db57112f95e3b9f007f6aff3.tar.gz
gentoo-cc7fabab6e85bfa0db57112f95e3b9f007f6aff3.tar.bz2
gentoo-cc7fabab6e85bfa0db57112f95e3b9f007f6aff3.zip
sys-apps/pkgcore: Bump to 0.12.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/pkgcore/Manifest1
-rw-r--r--sys-apps/pkgcore/pkgcore-0.12.8.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/sys-apps/pkgcore/Manifest b/sys-apps/pkgcore/Manifest
index 78f9a14a07fc..5b654489324e 100644
--- a/sys-apps/pkgcore/Manifest
+++ b/sys-apps/pkgcore/Manifest
@@ -1,3 +1,4 @@
DIST pkgcore-0.12.4.tar.gz 622553 BLAKE2B fc9df4f9499ad20cec439275880e469e1ffd8204b894c0a523ed27a3e55748e58634fca2af693fcc453e8aec068733a944331f7cea52e983e50981374239d534 SHA512 bc9eccd8d903e987df97354de008826dd52a7db0d9def064c56bb9425d1aa69e8fdf15dcfd0f86057c98a3c0adefee633a3c1cc9b689a334c126730cbdeafd0c
DIST pkgcore-0.12.6.tar.gz 624740 BLAKE2B fb03cffd274d8c31f6eff33a0f9133dc0ef84a7e671d6f29cda938fca3e353d498173ae3e5ce7c5b7433e5e668096ae63ed7c4cc7108ad6edc7db3c247ce85df SHA512 18d01f7a52a7aeae0fcfd8ce81e27f98a204c3743e211a2dd182cabd6521c9d528663affbd98521a41ada17cbece860fce61d9e6a2dff2ca525da26741807c95
DIST pkgcore-0.12.7.tar.gz 624992 BLAKE2B 93058dcf8eae891a7462b3125d648c218c034388daa8be86b4cbea34b82cbe7c484f354f4bf94bb3e4f25858783402d172231f773aded15b4dd902e52f9a3620 SHA512 2d25c3262a3fa806514d64a2f15664b8f0fe3ab2946ae681dd0ba7cebd8c9c9490500f809907f40eb5072763134d4e68cd75d17b2b7321a33fb55ebdad0768a7
+DIST pkgcore-0.12.8.tar.gz 624442 BLAKE2B d7e15fc659820e3cd6e4f7848413c12b2439d38900c9f64c582ba078d3fe874c12d66d39fdf59a7e4ff585d82d29fcad16c9af869b2388ed6e0af0be7d16d887 SHA512 d02087d4bada3bc2f87738b0ddedc72782b2facdf681927e84fed32dc6645e48ebde83de5aeb9eb0f64e01afe2ac511ae0f7450a2708698bbad872a60044319b
diff --git a/sys-apps/pkgcore/pkgcore-0.12.8.ebuild b/sys-apps/pkgcore/pkgcore-0.12.8.ebuild
new file mode 100644
index 000000000000..5c7eeb03645d
--- /dev/null
+++ b/sys-apps/pkgcore/pkgcore-0.12.8.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_IN_SOURCE_BUILD=1
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/pkgcore.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="a framework for package management"
+HOMEPAGE="https://github.com/pkgcore/pkgcore"
+
+LICENSE="BSD MIT"
+SLOT="0"
+
+RDEPEND="
+ >=app-shells/bash-5.0
+ dev-python/lxml[${PYTHON_USEDEP}]"
+if [[ ${PV} == *9999 ]]; then
+ RDEPEND+=" ~dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
+else
+ RDEPEND+=" >=dev-python/snakeoil-0.9.6[${PYTHON_USEDEP}]"
+fi
+BDEPEND="
+ test? (
+ >=dev-python/pytest-6[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests setup.py
+
+src_test() {
+ local -x PYTHONDONTWRITEBYTECODE=
+ distutils-r1_src_test
+}
+
+python_install_all() {
+ local DOCS=( NEWS.rst )
+ [[ ${PV} == *9999 ]] || doman man/*
+ distutils-r1_python_install_all
+}