summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2022-07-17 08:40:34 -0500
committerBen Kohler <bkohler@gentoo.org>2022-07-17 08:41:03 -0500
commitb965d3249199bdfbcb92361a91be5bff09c2a4e8 (patch)
tree75d09d823d8bc26937abac1618aa07bce0440f6c /sys-apps
parentnet-wireless/iwd: add 1.29 (diff)
downloadgentoo-b965d3249199bdfbcb92361a91be5bff09c2a4e8.tar.gz
gentoo-b965d3249199bdfbcb92361a91be5bff09c2a4e8.tar.bz2
gentoo-b965d3249199bdfbcb92361a91be5bff09c2a4e8.zip
sys-apps/hwinfo: add 21.82
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/hwinfo/Manifest1
-rw-r--r--sys-apps/hwinfo/hwinfo-21.82.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/sys-apps/hwinfo/Manifest b/sys-apps/hwinfo/Manifest
index b694d121b74b..e83fa3d068c0 100644
--- a/sys-apps/hwinfo/Manifest
+++ b/sys-apps/hwinfo/Manifest
@@ -1,2 +1,3 @@
DIST hwinfo-21.80-1.1.src.rpm 968192 BLAKE2B a11a1060137ff89504963c01c4129dcac93e8eea9747ea20272763f648068e8b4fb3f1c31ae761664b1b1ffedf32971b3b27804f125473f0367cc6eed03751bf SHA512 7bf64d9ee6b2381c43ffb22dc5623c8a8ed05c26b4e154c3093a9cb255779a1d482c18cd085b272ce619249743f1c43989337bed142685b4d6c634f4551893ee
DIST hwinfo-21.81-1.3.src.rpm 967951 BLAKE2B af6c390cd327ac2683f6b92a7847c5a0dc99e7553e35b7a5fd07db0a7f60c671a303e85061e1656474792b921e0d1b8ad18591f22a5da557879743d91151509a SHA512 eef89b5c8c029f606d66eb1740c4d046baaf490fc39d42d0137d1c4c5b248b0ddbe34b1532dbcef10f408677f173cfeb11d4c3e801a6a90280e1a6babc245674
+DIST hwinfo-21.82-1.1.src.rpm 968922 BLAKE2B 5a491e7ca7125b40205dfa0e28350124f3deab6438424289ec44588940c47ddd341c9a7705edd3b9678b80050e26acdad1e9ea4aa7bc47e1af670ae020bfec51 SHA512 7221430e67bd76016d535db823e5e66034001c24e49de656365b421ef528bdcdf94ad82399f6a5916e55dc0b9f2dc1873a0e9ae2813025b746999bb2c5bd02df
diff --git a/sys-apps/hwinfo/hwinfo-21.82.ebuild b/sys-apps/hwinfo/hwinfo-21.82.ebuild
new file mode 100644
index 000000000000..a54748333293
--- /dev/null
+++ b/sys-apps/hwinfo/hwinfo-21.82.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit rpm toolchain-funcs
+
+DESCRIPTION="Hardware detection tool used in SuSE Linux"
+HOMEPAGE="https://github.com/openSUSE/hwinfo/"
+#Using srpms from SUSE to get pregenerated changelog, otherwise we could use GH
+#SRC_URI="https://github.com/openSUSE/hwinfo/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="http://download.opensuse.org/tumbleweed/repo/src-oss/src/${P}-1.1.src.rpm"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ amd64? ( dev-libs/libx86emu )
+ x86? ( dev-libs/libx86emu )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ >=sys-kernel/linux-headers-2.6.17"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_prepare() {
+ # Respect AR variable.
+ sed -i \
+ -e 's:ar r:$(AR) r:' \
+ src/{,isdn,ids,smp,hd}/Makefile || die
+
+ # Respect LDFLAGS.
+ sed -i -e 's:$(CC) $(CFLAGS):$(CC) $(LDFLAGS) $(CFLAGS):' src/ids/Makefile || die
+
+ # Respect MAKE variable. Skip forced -pipe and -g. Respect LDFLAGS.
+ sed -i \
+ -e 's:make:$(MAKE):' \
+ -e 's:-pipe -g::' \
+ -e 's:LDFLAGS.*=:LDFLAGS +=:' \
+ Makefile{,.common} || die
+ # Workaround from Arch, if using source tarballs from github
+ # echo 'touch changelog' > git2log
+ default
+}
+
+src_compile() {
+ tc-export AR
+ emake CC="$(tc-getCC)" RPM_OPT_FLAGS="${CFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" LIBDIR="/usr/$(get_libdir)" install
+ keepdir /var/lib/hardware/udi
+
+ dodoc changelog README*
+ docinto examples
+ dodoc doc/example*.c
+ doman doc/*.{1,8}
+}