summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Burgess IV <gbiv@google.com>2023-08-09 13:25:38 -0600
committerBen Kohler <bkohler@gentoo.org>2023-09-01 19:23:54 -0500
commit791ea6cb7a7ab2eb006a947bb74275e1fceaf98b (patch)
treeef0758e78bf689b714c613fd3553a951ab3043ae /sys-apps
parentapp-emulation/wine-vanilla: add 8.15 (diff)
downloadgentoo-791ea6cb7a7ab2eb006a947bb74275e1fceaf98b.tar.gz
gentoo-791ea6cb7a7ab2eb006a947bb74275e1fceaf98b.tar.bz2
gentoo-791ea6cb7a7ab2eb006a947bb74275e1fceaf98b.zip
sys-apps/lshw: force c++14 in version 02.19.2b_p20210121
Clang has used C++17 as its default standard since clang-16 (released 17-Mar-2023). This version of lshw does not compile cleanly with this new standard. Keep it on C++14, since newer versions compile without issue. Signed-off-by: George Burgess IV <gbiv@google.com> Closes: https://github.com/gentoo/gentoo/pull/32235 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/lshw/lshw-02.19.2b_p20210121-r4.ebuild (renamed from sys-apps/lshw/lshw-02.19.2b_p20210121-r3.ebuild)5
1 files changed, 5 insertions, 0 deletions
diff --git a/sys-apps/lshw/lshw-02.19.2b_p20210121-r3.ebuild b/sys-apps/lshw/lshw-02.19.2b_p20210121-r4.ebuild
index 527ff09582af..1b0a868d5049 100644
--- a/sys-apps/lshw/lshw-02.19.2b_p20210121-r3.ebuild
+++ b/sys-apps/lshw/lshw-02.19.2b_p20210121-r4.ebuild
@@ -65,6 +65,11 @@ src_prepare() {
src_compile() {
tc-export CC CXX AR PKG_CONFIG
use static && append-ldflags -static
+ # Some toolchains are defaulting to C++17, which causes
+ # `<sys-apps/lshw-02.19.2b_p20220831` to break due to its use of the
+ # `register` keyword. Just pin it at 14, since future versions don't
+ # have this issue.
+ append-cxxflags '-std=c++14'
# Need two sep make statements to avoid parallel build issues. #588174
local sqlite=$(usex sqlite 1 0)