summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-15 00:12:17 -0400
committerSam James <sam@gentoo.org>2024-03-15 04:14:17 +0000
commit4ea1b2361e90456b422cc08bc8d5c9f8e8241990 (patch)
tree626cfb824f6fea84cfb2bbcef697cfb175ca8fdc /sys-apps
parentsys-apps/sg3_utils: make sure elibtoolize is applied (diff)
downloadgentoo-4ea1b2361e90456b422cc08bc8d5c9f8e8241990.tar.gz
gentoo-4ea1b2361e90456b422cc08bc8d5c9f8e8241990.tar.bz2
gentoo-4ea1b2361e90456b422cc08bc8d5c9f8e8241990.zip
sys-apps/sg3_utils: update EAPI 7 -> 8
Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/sg3_utils/sg3_utils-1.47-r2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sys-apps/sg3_utils/sg3_utils-1.47-r2.ebuild b/sys-apps/sg3_utils/sg3_utils-1.47-r2.ebuild
new file mode 100644
index 000000000000..7713ea4da2c5
--- /dev/null
+++ b/sys-apps/sg3_utils/sg3_utils-1.47-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit libtool
+
+DESCRIPTION="Apps for querying the sg SCSI interface"
+HOMEPAGE="https://sg.danny.cz/sg/"
+#SRC_URI="https://github.com/hreinecke/sg3_utils/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://sg.danny.cz/sg/p/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="static-libs"
+
+RDEPEND="!sys-apps/rescan-scsi-bus"
+
+PATCHES=(
+ # Bug #828897
+ "${FILESDIR}"/${PN}-1.47-musl.patch
+)
+
+src_prepare() {
+ default
+ elibtoolize
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ dodoc COVERAGE doc/README examples/*.txt
+ newdoc scripts/README README.scripts
+
+ find "${ED}" -type f -name "*.la" -delete || die
+
+ # Better fix for bug 231089; some packages look for sgutils2
+ local path lib
+ path="/usr/$(get_libdir)"
+ for lib in "${ED}/"${path}/libsgutils2{,-${PV}}.*; do
+ lib=${lib##*/}
+ dosym "${lib}" "${path}/${lib/libsgutils2/libsgutils}"
+ done
+}