summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2023-06-15 16:05:09 -0400
committerMike Gilbert <floppym@gentoo.org>2023-06-15 16:29:19 -0400
commit34d3f70685487b608f1b5485284d86dc2ceb250b (patch)
treeb7b32cf29c212bf63960f2c1ee6fc77cf23f02bf /sys-apps
parentwww-client/vivaldi: Add version 6.1.3035.84 (diff)
downloadgentoo-34d3f70685487b608f1b5485284d86dc2ceb250b.tar.gz
gentoo-34d3f70685487b608f1b5485284d86dc2ceb250b.tar.bz2
gentoo-34d3f70685487b608f1b5485284d86dc2ceb250b.zip
sys-apps/musl-locales: new package, add 0.1.0
Bug: https://bugs.gentoo.org/864963 Bug: https://bugs.gentoo.org/865867 Bug: https://bugs.gentoo.org/874636 Bug: https://bugs.gentoo.org/898528 Bug: https://bugs.gentoo.org/906015 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/musl-locales/Manifest1
-rw-r--r--sys-apps/musl-locales/metadata.xml7
-rw-r--r--sys-apps/musl-locales/musl-locales-0.1.0.ebuild21
3 files changed, 29 insertions, 0 deletions
diff --git a/sys-apps/musl-locales/Manifest b/sys-apps/musl-locales/Manifest
new file mode 100644
index 000000000000..a3e2f4919b40
--- /dev/null
+++ b/sys-apps/musl-locales/Manifest
@@ -0,0 +1 @@
+DIST musl-locales-0.1.0.tar.xz 26744 BLAKE2B 9ad696e7006a124f2e633e3f5476b68806659ddeac2e7cbd0ce485087870463256f3dcc11c3d37074cfc863ce8afed1b31bdf7c80435cce182fce95e81bf16b0 SHA512 bc1e581676ef21aa22b85932186189ba5fd0b1701feef4906f42baa296a90fc6886101d02a46a9560b883aad42aa4808ed46c5dddc09d97d1a0f75943a0d456a
diff --git a/sys-apps/musl-locales/metadata.xml b/sys-apps/musl-locales/metadata.xml
new file mode 100644
index 000000000000..6b00211d29ea
--- /dev/null
+++ b/sys-apps/musl-locales/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>musl@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/sys-apps/musl-locales/musl-locales-0.1.0.ebuild b/sys-apps/musl-locales/musl-locales-0.1.0.ebuild
new file mode 100644
index 000000000000..c50b7a93e29b
--- /dev/null
+++ b/sys-apps/musl-locales/musl-locales-0.1.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Locale program for musl libc"
+HOMEPAGE="https://git.adelielinux.org/adelie/musl-locales"
+SRC_URI="https://git.adelielinux.org/adelie/musl-locales/uploads/7e855b894b18ca4bf4ecb11b5bcbc4c1/${P}.tar.xz"
+
+LICENSE="LGPL-3 MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_configure() {
+ local mycmakeargs=(
+ -DLOCALE_PROFILE=OFF
+ )
+ cmake_src_configure
+}