summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-08-01 17:08:47 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-08-01 17:08:47 +0200
commit2866f4373027f71ee945cbe06a13f23fc44ac846 (patch)
tree1f96a72eb0bbc94a60dbfeff2345d39a7eba47a9 /sys-apps
parentsys-apps/kexec-tools: Bump to version 2.0.15 (diff)
downloadgentoo-2866f4373027f71ee945cbe06a13f23fc44ac846.tar.gz
gentoo-2866f4373027f71ee945cbe06a13f23fc44ac846.tar.bz2
gentoo-2866f4373027f71ee945cbe06a13f23fc44ac846.zip
sys-apps/kexec-tools: Sync live ebuild.
Package-Manager: Portage-2.3.6, Repoman-2.3.3 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/kexec-tools/kexec-tools-9999.ebuild19
1 files changed, 12 insertions, 7 deletions
diff --git a/sys-apps/kexec-tools/kexec-tools-9999.ebuild b/sys-apps/kexec-tools/kexec-tools-9999.ebuild
index fb38edc70a07..f3f01574c051 100644
--- a/sys-apps/kexec-tools/kexec-tools-9999.ebuild
+++ b/sys-apps/kexec-tools/kexec-tools-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=6
if [[ ${PV} == "9999" ]] ; then
inherit git-r3
@@ -9,10 +9,10 @@ if [[ ${PV} == "9999" ]] ; then
AUTOTOOLS_AUTORECONF=true
else
SRC_URI="mirror://kernel/linux/utils/kernel/kexec/${P}.tar.xz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~amd64 ~arm64 ~x86"
fi
-inherit autotools-utils linux-info systemd
+inherit libtool linux-info systemd
DESCRIPTION="Load another kernel from the currently executing Linux kernel"
HOMEPAGE="https://kernel.org/pub/linux/utils/kernel/kexec/"
@@ -40,6 +40,11 @@ pkg_setup() {
export ASFLAGS="${CCASFLAGS}"
}
+src_prepare() {
+ default
+ elibtoolize
+}
+
src_configure() {
local myeconfargs=(
$(use_with booke)
@@ -47,15 +52,15 @@ src_configure() {
$(use_with xen)
$(use_with zlib)
)
- autotools-utils_src_configure
+ econf "${myeconfargs[@]}"
}
src_install() {
- autotools-utils_src_install
+ default
dodoc "${FILESDIR}"/README.Gentoo
- newinitd "${FILESDIR}"/kexec.init-2.0.12 kexec
+ newinitd "${FILESDIR}"/kexec.init-2.0.13-r1 kexec
newconfd "${FILESDIR}"/kexec.conf-2.0.4 kexec
insinto /etc